summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 12 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f85775090a1..9d484d7e69d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gophcatch-git
pkgdesc = Watch gopher holes and catch updates
- pkgver = 20111106
+ pkgver = 13.01
pkgrel = 1
url = https://github.com/vain/gophcatch
arch = any
@@ -9,6 +9,8 @@ pkgbase = gophcatch-git
depends = curl
optdepends = lynx: Needed if you want to dump new items
optdepends = cron: Recommended if you want to regularly run gophcatch
+ source = git://github.com/vain/gophcatch.git
+ md5sums = SKIP
pkgname = gophcatch-git
diff --git a/PKGBUILD b/PKGBUILD
index 66e8a4659ad8..0bad8b064042 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
-pkgname=gophcatch-git
-pkgver=20111106
+_pkgname=gophcatch
+pkgname=$_pkgname-git
+pkgver=13.01
pkgrel=1
pkgdesc="Watch gopher holes and catch updates"
arch=('any')
@@ -12,31 +13,16 @@ optdepends=(
'lynx: Needed if you want to dump new items'
'cron: Recommended if you want to regularly run gophcatch'
)
+source=(git://github.com/vain/gophcatch.git)
+md5sums=('SKIP')
-_gitroot="git://github.com/vain/gophcatch.git"
-_gitname="master"
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed 's|-|.|g; s|v||'
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_pkgname"
install -Dm755 gophcatch "$pkgdir"/usr/bin/gophcatch
install -Dm644 man1/gophcatch.1 "$pkgdir"/usr/share/man/man1/gophcatch.1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"