summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--.python-version1
-rw-r--r--Makefile15
-rw-r--r--PKGBUILD38
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d65d5e4d8bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = govuk-guix-git
+ pkgdesc = CLI for GDS Staff
+ pkgver = r22071.8d3fbcde3
+ pkgrel = 1
+ url = https://github.com/alphagov/govuk-guix
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = govuk-guix=r22071.8d3fbcde3
+ conflicts = govuk-guix
+ source = govuk-guix-git::git+https://github.com/alphagov/govuk-guix
+ sha512sums = SKIP
+
+pkgname = govuk-guix-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..98b7827cc492
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+govuk-guix-git
+pkg
+src
+*.tar.xz
diff --git a/.python-version b/.python-version
new file mode 100644
index 000000000000..bec3a35ee8b4
--- /dev/null
+++ b/.python-version
@@ -0,0 +1 @@
+system
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d9cf3181e263
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+.PHONY: PKGBUILD clean package
+
+all: PKGBUILD .SRCINFO
+
+PKGBUILD:
+ makepkg -docC
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+package: .SRCINFO
+ makepkg
+
+clean:
+ rm -rf govuk-guix-git pkg src completion *.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5f1da9f2c7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tom Whitwell <tom.whitwell@digital.cabinet-office.gov.uk>
+pkgname=govuk-guix-git
+pkgver=r22071.8d3fbcde3
+pkgrel=1
+pkgdesc="CLI for GDS Staff"
+arch=('any')
+url="https://github.com/alphagov/govuk-guix"
+license=('MIT')
+makedepends=('git' 'ruby')
+provides=("govuk-guix=${pkgver}")
+conflicts=('govuk-guix')
+source=("${pkgname}"::"git+https://github.com/alphagov/govuk-guix")
+sha512sums=('SKIP')
+
+pkgver() {
+ pushd "${srcdir}/${pkgname}" >/dev/null
+ {
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+ popd >/dev/null
+}
+
+package() {
+ msg2 'gds binary'
+ pushd "${srcdir}/${pkgname}/bin" >/dev/null
+ {
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 govuk* "${pkgdir}/usr/bin"
+ }
+ popd >/dev/null
+
+ msg2 'license'
+ pushd "${srcdir}/${pkgname}" >/dev/null
+ {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ }
+ popd >/dev/null
+}