summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rwxr-xr-xgoxel.desktop8
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0db59c196e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = goxel-voxel-editor-git
+ pkgdesc = Open Source 3D voxel editor for Mac, Windows and Linux. Git version.
+ pkgver = 0.10.0.r69.5ce340a
+ pkgrel = 1
+ url = https://guillaumechereau.github.io/goxel/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = scons
+ makedepends = pkg-config
+ depends = glfw
+ depends = gtk3
+ provides = goxel
+ conflicts = goxel
+ source = git+https://github.com/guillaumechereau/goxel.git
+ source = goxel.desktop
+ sha256sums = SKIP
+ sha256sums = 9b29df7405a9593396bc7ea810dc2871cce7c4ee474c1fa56d32f56c2ca2d921
+
+pkgname = goxel-voxel-editor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d915b4956cb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alexey Trifonov <otaku [at] rambler dot ru>
+# Contributor: Tesx <tesfabpel@gmail.com>
+pkgname=goxel-voxel-editor-git
+pkgver=0.10.0.r69.5ce340a
+pkgrel=1
+pkgdesc="Open Source 3D voxel editor for Mac, Windows and Linux. Git version."
+arch=('i686' 'x86_64')
+conflicts=('goxel')
+provides=('goxel')
+url="https://guillaumechereau.github.io/goxel/"
+license=('GPL3')
+groups=()
+makedepends=(scons pkg-config)
+depends=(glfw gtk3)
+source=(
+ "git+https://github.com/guillaumechereau/goxel.git"
+ "goxel.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ '9b29df7405a9593396bc7ea810dc2871cce7c4ee474c1fa56d32f56c2ca2d921'
+)
+
+_gitname=goxel
+
+pkgver() {
+
+ cd $_gitname
+ printf "%s" "$(git describe --first-parent --long --tags | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
+
+}
+
+build() {
+ cd $_gitname
+ make release
+}
+
+package() {
+ install -Dm644 goxel.desktop "$pkgdir/usr/share/applications/goxel.desktop"
+ install -Dm644 goxel/icon.png "$pkgdir/usr/share/icons/goxel.png"
+
+ cd $_gitname
+ install -Dm755 goxel "$pkgdir/usr/bin/goxel"
+}
diff --git a/goxel.desktop b/goxel.desktop
new file mode 100755
index 000000000000..1be5bc29e739
--- /dev/null
+++ b/goxel.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Goxel
+Comment=Open Source 3D voxel editor for Mac, Windows and Linux.
+TryExec=goxel
+Exec=goxel
+Icon=goxel
+Type=Application
+Categories=Graphics;3DGraphics;