summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6a876c543b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gpick-git
+ pkgdesc = Advanced color picker written in C++ using GTK+ toolkit
+ pkgver = 0.2.6rc1.r41.g3b17cf9
+ pkgrel = 1
+ url = http://www.gpick.org/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ makedepends = boost
+ makedepends = cmake
+ makedepends = ragel
+ depends = boost-libs
+ depends = gtk3
+ depends = lua
+ provides = gpick
+ conflicts = gpick
+ source = git+https://github.com/thezbyg/gpick.git
+ sha256sums = SKIP
+
+pkgname = gpick-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2072845bf901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Alad Wenter <alad@mailbox.org>
+# Contributor: Martin Wimpress <code@flexion.org>
+
+pkgname=gpick-git
+pkgver=0.2.6rc1.r41.g3b17cf9
+pkgrel=1
+pkgdesc="Advanced color picker written in C++ using GTK+ toolkit"
+arch=(i686 x86_64 armv6h armv7h)
+url="http://www.gpick.org/"
+license=(BSD)
+depends=(boost-libs gtk3 lua)
+makedepends=(boost cmake ragel)
+provides=(gpick)
+conflicts=(gpick)
+source=("git+https://github.com/thezbyg/gpick.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd gpick
+ git describe --long --tags | sed 's/^gpick-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir build
+ cd build
+ cmake ../gpick -DCMAKE_INSTALL_PREFIX="/usr/"
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "../gpick/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}