summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rwxr-xr-x[-rw-r--r--]PKGBUILD95
-rw-r--r--gpmdp-git.install11
-rw-r--r--gpmdp.desktop11
4 files changed, 113 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62d3689dd631..cef21f357ea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,38 @@
-# Generated by makepkg 5.0.0
-# Mon Mar 7 03:38:40 UTC 2016
+# Generated by mksrcinfo v8
+# Mon May 30 23:56:15 UTC 2016
pkgbase = gpmdp-git
- pkgdesc = An electron wrapper for Google Play Music
- pkgver = r362.ba5539f
+ pkgdesc = A beautiful cross platform Desktop Player for Google Play Music.
+ pkgver = 3.2.4.47.g5f0babf
pkgrel = 1
- url = https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-
+ url = http://www.googleplaymusicdesktopplayer.com
+ install = gpmdp-git.install
+ arch = i686
arch = x86_64
license = MIT
- makedepends = git
+ makedepends = nodejs
+ makedepends = electron
makedepends = npm
- depends = nodejs
- provides = gpmdp-git
- conflicts = gpmdp-git
- conflicts = gpmdp
- source = Google-Play-Music-Desktop-Player-UNOFFICIAL-::git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git#branch=master
+ makedepends = git
+ makedepends = gcc
+ makedepends = libx11
+ depends = libnotify
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = avahi
+ optdepends = gnome-keyring
+ optdepends = lsb-release
+ optdepends = libxtst
+ optdepends = desktop-file-utils: Needed to update desktop icon database
+ provides = gpmdp
+ replaces = google-play-music-player-git
+ source = git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git
+ source = gpmdp.desktop
+ source = gpmdp-git.install
md5sums = SKIP
+ md5sums = 6e673c01e13025493e12e33eabe883c4
+ md5sums = e297b473f8fd1b6f26642da1d7206123
pkgname = gpmdp-git
diff --git a/PKGBUILD b/PKGBUILD
index b1000185f322..e4621f49014f 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,74 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: Brian Allred <brian.d.allred@gmail.com>
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
-# Maintainer: Kevin Minehart <kmineh0151@gmail.com>
pkgname=gpmdp-git
-_gitname=Google-Play-Music-Desktop-Player-UNOFFICIAL-
-pkgver=r362.ba5539f
+_name=Google-Play-Music-Desktop-Player-UNOFFICIAL-
+pkgver=3.2.4.72.gd25d92e
pkgrel=1
-pkgdesc="An electron wrapper for Google Play Music"
-arch=('x86_64')
-url="https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-"
+pkgdesc="A beautiful cross platform Desktop Player for Google Play Music."
+arch=('i686' 'x86_64')
+url="http://www.googleplaymusicdesktopplayer.com"
license=('MIT')
-depends=('nodejs')
-makedepends=('git' 'npm') # 'bzr', 'git', 'mercurial' or 'subversion'
-provides=("$pkgname")
-conflicts=("$pkgname" 'gpmdp')
-source=($_gitname::'git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git#branch=master')
-md5sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+depends=('libnotify' 'alsa-lib' 'gconf' 'gtk2' 'nss' 'avahi')
+makedepends=('nodejs' 'electron' 'npm' 'git' 'gcc' 'libx11')
+optdepends=('gnome-keyring' 'lsb-release' 'libxtst' 'desktop-file-utils: Needed to update desktop icon database')
+provides=('gpmdp')
+replaces=('google-play-music-player-git')
+conflicts=('google-play-music-player-git' 'gpmdp')
+install=gpmdp-git.install
+source=("git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git"
+ "gpmdp.desktop"
+ "gpmdp-git.install")
+md5sums=('SKIP'
+ '579876dec25ab5587bef333908af44eb'
+ 'e297b473f8fd1b6f26642da1d7206123')
-prepare() {
- cd "$srcdir/$_gitname"
- npm install
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --tags | sed 's/^v//' | sed 's/-/./g'
}
build() {
- cd "$srcdir/$_gitname"
- npm run package:linux
+ cd "$srcdir/$_name"
+ npm install
+ npm uninstall ll-keyboard-hook-win -O
+ npm update
+ npm run build
+
+ if [ $CARCH = "x86_64" ]
+ then
+ npm run package:linux:64
+ elif [ $CARCH = "i686" ]
+ then
+ npm run package:linux:32
+ fi
+
}
package() {
- cd "$srcdir/$_gitname/dist/"
- mkdir -p $pkgdir/usr/share/ $pkgdir/usr/bin
- mv 'Google Play Music Desktop Player-linux-x64' $pkgdir/usr/share/google-play-music-desktop-player
- ln -sf '/usr/share/google-play-music-desktop-player/Google Play Music Desktop Player' $pkgdir/usr/bin/google-play-music-desktop-player
-}
+ # remarks: this package structure is based on a debtap conversion of the .deb output of 'npm run make:linux'
+
+ cd "$pkgdir"
+
+ # remarks: is there a way to keep npm from building for both architectures?
+ if [ $CARCH = "x86_64" ]
+ then
+ dist_dir="$srcdir/$_name/dist/Google Play Music Desktop Player-linux-x64"
+ elif [ $CARCH = "i686" ]
+ then
+ dist_dir="$srcdir/$_name/dist/Google Play Music Desktop Player-linux-ia32"
+ fi
+ # make directories
+ mkdir -p usr/bin usr/share/applications/ usr/share/doc/gpmdp/ usr/share/pixmaps/ usr/share/gpmdp/
+
+ # copy license
+ cp "$dist_dir/LICENSE" usr/share/doc/gpmdp/
+ # copy icon
+ cp "$dist_dir/resources/app/build/assets/img/main.png" usr/share/pixmaps/gpmdp.png
+ # copy application
+ cp -r "$dist_dir"/* usr/share/gpmdp
+ # link binary
+ ln -s "/usr/share/gpmdp/Google Play Music Desktop Player" "usr/bin/gpmdp"
+ # create desktop entry
+ cp $srcdir/gpmdp.desktop usr/share/applications/
+}
diff --git a/gpmdp-git.install b/gpmdp-git.install
new file mode 100644
index 000000000000..80312d4a6041
--- /dev/null
+++ b/gpmdp-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/gpmdp.desktop b/gpmdp.desktop
new file mode 100644
index 000000000000..e4f02f0db915
--- /dev/null
+++ b/gpmdp.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Google Play Music Desktop Player
+Comment=An electron wrapper for Google Play Music
+GenericName=Google Play Music Desktop Player
+Exec=gpmdp %U
+Icon=gpmdp
+Type=Application
+StartupNotify=true
+Categories=GNOME;GTK;Multimedia;
+StartupWMClass=Google Play Music Desktop Player
+Name[en_US]=gpmdp