summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rw-r--r--fix-build.patch26
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1363c00f1957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gpointing-device-settings
+ pkgdesc = GUI tool for setting pointing device such as TrackPoint or Touchpad
+ pkgver = 1.5.1
+ pkgrel = 5
+ url = https://wiki.gnome.org/Attic/GPointingDeviceSettings
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-settings-daemon
+ makedepends = intltool
+ depends = gtk2
+ depends = gconf
+ source = http://sourceforge.jp/frs/redir.php?m=iij&f=/gsynaptics/45812/gpointing-device-settings-1.5.1.tar.gz
+ source = fix-build.patch
+ md5sums = 1d1491473df8eabca3c15c997a975d7f
+ md5sums = cc42b7bcd69fb43ae5bfbe6e1d540713
+
+pkgname = gpointing-device-settings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e451ae318fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Thomas Mudrunka <harvie@@email..cz>
+
+pkgname=gpointing-device-settings
+pkgver=1.5.1
+pkgrel=5
+pkgdesc="GUI tool for setting pointing device such as TrackPoint or Touchpad"
+arch=('x86_64')
+license=('GPL')
+url="https://wiki.gnome.org/Attic/GPointingDeviceSettings"
+depends=('gtk2' 'gconf')
+makedepends=('gnome-settings-daemon' 'intltool')
+source=("http://sourceforge.jp/frs/redir.php?m=iij&f=/gsynaptics/45812/$pkgname-$pkgver.tar.gz"
+ "fix-build.patch")
+md5sums=('1d1491473df8eabca3c15c997a975d7f'
+ 'cc42b7bcd69fb43ae5bfbe6e1d540713')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Fix build
+ patch -Np1 -i "${srcdir}/fix-build.patch"
+
+ # Disable GSD plugin (won't build with GSD 3.8)
+ sed -i 's/ gnome-settings-daemon-plugins//' modules/Makefile.am
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --disable-static --disable-schemas-install \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # Remove GConf schema (used by GSD plugin)
+ rm -r "${pkgdir}/usr/share/gconf"
+}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..341d96fc9b50
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,26 @@
+diff -Naur gpointing-device-settings-1.5.1.orig/configure.ac gpointing-device-settings-1.5.1/configure.ac
+--- gpointing-device-settings-1.5.1.orig/configure.ac 2010-02-05 00:38:20.000000000 +0100
++++ gpointing-device-settings-1.5.1/configure.ac 2013-12-17 15:00:08.394574115 +0100
+@@ -3,10 +3,9 @@
+
+ AC_INIT(gpointing-device-settings, 1.5.1,
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=GPointingDeviceSettings])
+-AM_INIT_AUTOMAKE([1.9 tar-pax])
+-AM_INIT_AUTOMAKE([foreign])
++AM_INIT_AUTOMAKE([1.9 tar-pax foreign])
+ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_MACRO_DIR([m4])
+
+ AM_PROG_LIBTOOL
+@@ -146,9 +145,6 @@
+
+ GPDS_CFLAGS="$XINPUT_CFLAGS $GTK_CFLAGS"
+ GPDS_CFLAGS="$GPDS_CFLAGS $GCONF2_CFLAGS"
+-GPDS_CFLAGS="$GPDS_CFLAGS -DGTK_DISABLE_DEPRECATED"
+-GPDS_CFLAGS="$GPDS_CFLAGS -DGDK_DISABLE_DEPRECATED"
+-GPDS_CFLAGS="$GPDS_CFLAGS -DG_DISABLE_DEPRECATED"
+ GPDS_CFLAGS="$GPDS_CFLAGS -DGPDS_MODULEDIR=\\\"\"\$(gpds_moduledir)\"\\\""
+ GPDS_CFLAGS="$GPDS_CFLAGS -DGPDS_DATADIR=\\\"\"\$(gpds_datadir)\"\\\""
+ GPDS_CFLAGS="$GPDS_CFLAGS -DGPDS_UIDIR=\\\"\"\$(gpds_uidir)\"\\\""