summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6c3146f4055..a5b0d86dcdd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gpshell
pkgdesc = gpshell GlobalPlatform command shell
- pkgver = 1.4.4
- pkgrel = 2
- url = http://sourceforge.net/projects/globalplatform/
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/kaoh/globalplatform
arch = i686
arch = x86_64
license = GPL3
+ makedepends = pandoc
depends = glibc
depends = globalplatform
- source = http://downloads.sourceforge.net/globalplatform/gpshell-1.4.4.tar.gz
- md5sums = f3e43b0809fe063b36a2d85c6d271c9d
+ source = https://github.com/kaoh/globalplatform/archive/3832300cc5ade0439c2757ead1cf04e0e946e903.zip
+ md5sums = da5b1e46ac40221406e51ddf8f82ef4e
pkgname = gpshell
-
diff --git a/PKGBUILD b/PKGBUILD
index 81f9692eb1b5..4b0dba0b7959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Submitter: Guenther Starnberger <gst@sysfrog.org>
-# Maintainer: Moritz Lipp <mlq@pwmt.org>
+# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com >
+# Contributor: Guenther Starnberger <gst@sysfrog.org>
+# Contributor: Moritz Lipp <mlq@pwmt.org>
pkgname=gpshell
-pkgver=1.4.4
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
+_commit=3832300cc5ade0439c2757ead1cf04e0e946e903
pkgdesc="gpshell GlobalPlatform command shell"
license=('GPL3')
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/globalplatform/"
+url="https://github.com/kaoh/globalplatform"
depends=('glibc' 'globalplatform')
-source=(http://downloads.sourceforge.net/globalplatform/gpshell-${pkgver}.tar.gz)
-md5sums=('f3e43b0809fe063b36a2d85c6d271c9d')
+makedepends=('pandoc')
+source=(https://github.com/kaoh/globalplatform/archive/$_commit.zip)
+md5sums=('da5b1e46ac40221406e51ddf8f82ef4e')
+prepare() {
+ cd globalplatform-$_commit/globalplatform/cmake_modules
+ sed -e 's/libglobalplatform)/globalplatform)/g' -i FindGlobalPlatform.cmake
+
+}
build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd globalplatform-$_commit/gpshell
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd globalplatform-$_commit/gpshell
make DESTDIR=$pkgdir install
}