summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1eb26ba51ebf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gptscript
+ pkgdesc = Scripting AI for fun and profit
+ pkgver = v0.1.0
+ pkgrel = 1
+ url = https://gptscript.ai/
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ makedepends = npm
+ makedepends = yarn
+ conflicts = gptscript-git
+ source = gptscript-v0.1.0::git+https://github.com/gptscript-ai/gptscript#tag=v0.1.0
+ md5sums = SKIP
+
+pkgname = gptscript
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04a15090dc15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: drpebcak <tayworm@gmail.com>
+pkgname='gptscript'
+pkgver="v0.1.0"
+pkgrel=1
+pkgdesc="Scripting AI for fun and profit"
+arch=('x86_64')
+url="https://gptscript.ai/"
+license=('Apache')
+makedepends=('git' 'go' 'npm' 'yarn')
+source=("gptscript-$pkgver::git+https://github.com/gptscript-ai/gptscript#tag=$pkgver")
+noextract=()
+md5sums=('SKIP')
+conflicts=('gptscript-git')
+
+build() {
+ cd "gptscript-$pkgver"
+ make build-ui
+ make build
+}
+
+check() {
+ cd "gptscript-$pkgver"
+ ./bin/gptscript -v
+}
+
+package() {
+ cd "gptscript-$pkgver"
+ install -Dm755 bin/gptscript "$pkgdir"/usr/bin/gptscript
+}