summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78db47f48672..257f76704e65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gpu-viewer
pkgdesc = A frontend to glxinfo and vulkaninfo.
- pkgver = 1.43
+ pkgver = 2.02
pkgrel = 1
url = https://github.com/arunsivaramanneo/GPU-Viewer/
arch = i686
@@ -9,7 +9,8 @@ pkgbase = gpu-viewer
license = GPL3
makedepends = meson
makedepends = ninja
- depends = gtk3
+ depends = gtk4
+ depends = libadwaita
depends = python
depends = python-gobject
depends = python-click
@@ -19,9 +20,10 @@ pkgbase = gpu-viewer
depends = vdpauinfo
optdepends = nvidia: Vulkan nvidia driver
optdepends = mesa
+ optdepends = orchis-theme: Preferred GTK theme
optdepends = vulkan-radeon: Vulkan AMD drivers
optdepends = vulkan-intel: Vulkan Intel drivers
- source = https://github.com/arunsivaramanneo/GPU-Viewer/archive/v1.43.tar.gz
- md5sums = 7ad98f2d1351337f46072373c9eabec6
+ source = https://github.com/arunsivaramanneo/GPU-Viewer/archive/v2.02.tar.gz
+ md5sums = 0472cf12c84288e2dad4bb2ddbc3f0e7
pkgname = gpu-viewer
diff --git a/PKGBUILD b/PKGBUILD
index f2f5e3116385..44bceef95c55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
pkgname=gpu-viewer
_pkgname=GPU-Viewer
-pkgver=1.43
+pkgver=2.02
pkgrel=1
pkgdesc="A frontend to glxinfo and vulkaninfo."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/arunsivaramanneo/GPU-Viewer/"
license=('GPL3')
-depends=('gtk3' 'python' 'python-gobject' 'python-click' 'vulkan-tools' 'clinfo' 'mesa-utils' 'vdpauinfo')
+depends=('gtk4' 'libadwaita' 'python' 'python-gobject' 'python-click' 'vulkan-tools' 'clinfo' 'mesa-utils' 'vdpauinfo')
makedepends=('meson' 'ninja')
optdepends=('nvidia: Vulkan nvidia driver'
'mesa'
+ 'orchis-theme: Preferred GTK theme'
'vulkan-radeon: Vulkan AMD drivers'
'vulkan-intel: Vulkan Intel drivers')
source=("https://github.com/arunsivaramanneo/$_pkgname/archive/v$pkgver.tar.gz")
build() {
cd "$_pkgname-$pkgver"
- meson -D prefix=/usr _build
+ meson setup -D prefix=/usr _build
}
package() {
@@ -26,4 +27,4 @@ package() {
DESTDIR="$pkgdir" ninja install
}
-md5sums=('7ad98f2d1351337f46072373c9eabec6')
+md5sums=('0472cf12c84288e2dad4bb2ddbc3f0e7')