summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4def03ff681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gpup
+ pkgdesc = A command to upload photos and movies to your Google Photos Library
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/int128/gpup
+ arch = x86_64
+ license = Apache
+ makedepends = go-pie
+ source = https://github.com/int128/gpup/archive/1.6.1.tar.gz
+ sha256sums = c36490c8ecb0f1b68d4e5947a45a03398f376d666f8037e6be43dd7bf95f901d
+
+pkgname = gpup
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50de31221d25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adam Harvey <adam@adamharvey.name>
+
+pkgname=gpup
+pkgver=1.6.1
+pkgrel=1
+pkgdesc='A command to upload photos and movies to your Google Photos Library'
+arch=('x86_64')
+url="https://github.com/int128/gpup"
+license=('Apache')
+makedepends=('go-pie')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('c36490c8ecb0f1b68d4e5947a45a03398f376d666f8037e6be43dd7bf95f901d')
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}