summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--fix-quit-shortcut.diff37
3 files changed, 52 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80dac1beb5ba..27214f597072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.1.3
-# Sun Aug 25 20:31:37 UTC 2019
+# Tue Sep 10 08:23:08 UTC 2019
pkgbase = gpxlab
pkgdesc = Program to show and manipulate GPS tracks
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://bourgeoislab.wordpress.com/gpxlab/
arch = x86_64
license = GPL3
@@ -12,7 +12,9 @@ pkgbase = gpxlab
provides = gpxlab=0.6.0
conflicts = gpxlab-git
source = https://github.com/BourgeoisLab/GPXLab/archive/v0.6.0.tar.gz
+ source = fix-quit-shortcut.diff
sha256sums = 9b563dbdec884405c740bca63c57f275f2962ed0d84c3bc5ad8872141a65f7ff
+ sha256sums = SKIP
pkgname = gpxlab
diff --git a/PKGBUILD b/PKGBUILD
index 4497de308540..805e9cc62443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _orgname=BourgeoisLab
_pkgname=GPXLab
pkgname=${_pkgname,,}
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Program to show and manipulate GPS tracks'
arch=(x86_64)
url='https://bourgeoislab.wordpress.com/gpxlab/'
@@ -12,8 +12,16 @@ depends=('qt5-base')
makedepends=('qt5-tools')
provides=("${pkgname}=${pkgver}")
conflicts=(${pkgname}-git)
-source=("https://github.com/${_orgname}/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('9b563dbdec884405c740bca63c57f275f2962ed0d84c3bc5ad8872141a65f7ff')
+source=("https://github.com/${_orgname}/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "fix-quit-shortcut.diff")
+sha256sums=('9b563dbdec884405c740bca63c57f275f2962ed0d84c3bc5ad8872141a65f7ff'
+ 'SKIP')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ patch -Np1 < ../fix-quit-shortcut.diff
+}
build() {
cd ${_pkgname}-${pkgver}
diff --git a/fix-quit-shortcut.diff b/fix-quit-shortcut.diff
new file mode 100644
index 000000000000..3bb34a532deb
--- /dev/null
+++ b/fix-quit-shortcut.diff
@@ -0,0 +1,37 @@
+--- GPXLab-0.6.0/GPXLab/gpxlab.ui.orig 2019-09-10 11:19:23.098925713 +0300
++++ GPXLab-0.6.0/GPXLab/gpxlab.ui 2019-09-10 11:19:51.539243525 +0300
+@@ -1205,7 +1205,7 @@
+ <string>Exit application</string>
+ </property>
+ <property name="shortcut">
+- <string>Alt+F4</string>
++ <string>Ctrl+Q</string>
+ </property>
+ </action>
+ <action name="actionOpen">
+--- GPXLab-0.6.0/GPXLab/locale/gpxlab_ru.ts.orig 2019-09-10 11:19:37.115749051 +0300
++++ GPXLab-0.6.0/GPXLab/locale/gpxlab_ru.ts 2019-09-10 11:20:20.926238290 +0300
+@@ -767,8 +767,8 @@
+ </message>
+ <message>
+ <location filename="../gpxlab.ui" line="1208"/>
+- <source>Alt+F4</source>
+- <translation>Alt+F4</translation>
++ <source>Ctrl+Q</source>
++ <translation>Ctrl+Q</translation>
+ </message>
+ <message>
+ <location filename="../gpxlab.ui" line="311"/>
+--- GPXLab-0.6.0/GPXLab/locale/gpxlab_fi.ts.orig 2019-09-10 11:19:31.282350525 +0300
++++ GPXLab-0.6.0/GPXLab/locale/gpxlab_fi.ts 2019-09-10 11:20:08.026094295 +0300
+@@ -767,8 +767,8 @@
+ </message>
+ <message>
+ <location filename="../gpxlab.ui" line="1208"/>
+- <source>Alt+F4</source>
+- <translation>Alt+F4</translation>
++ <source>Ctrl+Q</source>
++ <translation>Ctrl+Q</translation>
+ </message>
+ <message>
+ <location filename="../gpxlab.ui" line="311"/>