summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--gr-framework-0.46.0.patch91
3 files changed, 8 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6d787632498..2c956f211cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gr-framework
pkgdesc = A universal framework for cross-platform visualization applications.
- pkgver = 0.46.0
- pkgrel = 3
+ pkgver = 0.47.0
+ pkgrel = 1
url = https://gr-framework.org
arch = i686
arch = x86_64
@@ -27,10 +27,8 @@ pkgbase = gr-framework
depends = qt5-base
depends = zlib
optdepends = ffmpeg: video support
- source = https://github.com/sciapp/gr/archive/v0.46.0.tar.gz
- source = gr-framework-0.46.0.patch
- sha256sums = c466ae98fd26ac8a30d1b35a899201eaf0ede593b0a3f61f806c49261acb6982
- sha256sums = 6e5a7e0997170c6df5b86ad5629a0750e9b5fe17749b279d4aaf27d845d1cb6a
+ source = https://github.com/sciapp/gr/archive/v0.47.0.tar.gz
+ sha256sums = aa501ed6e516d06382e6734c86d86d1363d81e9a6451cbcc1750ec80066c8a91
pkgname = gr-framework
diff --git a/PKGBUILD b/PKGBUILD
index 72056f167031..fcf1b5edcbef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ingo Heimbach <i.heimbach@fz-juelich.de>
pkgname="gr-framework"
-pkgver="0.46.0"
-pkgrel="3"
+pkgver="0.47.0"
+pkgrel="1"
pkgdesc="A universal framework for cross-platform visualization applications."
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
url="https://gr-framework.org"
@@ -12,16 +12,8 @@ depends=("bzip2" "cairo" "fontconfig" "freetype2" "ghostscript" "glfw-x11" \
"qhull" "qt5-base" "zlib")
makedepends=("cmake")
optdepends=("ffmpeg: video support")
-source=("https://github.com/sciapp/gr/archive/v${pkgver}.tar.gz"
- "${pkgname}-${pkgver}.patch")
-sha256sums=("c466ae98fd26ac8a30d1b35a899201eaf0ede593b0a3f61f806c49261acb6982"
- "6e5a7e0997170c6df5b86ad5629a0750e9b5fe17749b279d4aaf27d845d1cb6a")
-
-prepare() {
- cd "${srcdir}/gr-${pkgver}" || return
- patch -Np1 -i "${srcdir}/${pkgname}-${pkgver}.patch" && \
- echo "${pkgver}" > version.txt
-}
+source=("https://github.com/sciapp/gr/archive/v${pkgver}.tar.gz")
+sha256sums=("aa501ed6e516d06382e6734c86d86d1363d81e9a6451cbcc1750ec80066c8a91")
build() {
cd "${srcdir}/gr-${pkgver}" || return
diff --git a/gr-framework-0.46.0.patch b/gr-framework-0.46.0.patch
deleted file mode 100644
index c342b20665a4..000000000000
--- a/gr-framework-0.46.0.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
-index 64718ef9..911dd62d 100644
---- a/.gitlab-ci.yml
-+++ b/.gitlab-ci.yml
-@@ -443,10 +443,11 @@ arch-cmake-system-dependencies:
- stage: build
- image: iffregistry.fz-juelich.de/docker-images/gr-build-images/arch-system-dependencies
- script:
-- - make -C 3rdparty default TARGETS="qhull"
-+ - pacman -Sy
-+ - pacman -S --noconfirm --needed qhull
- - mkdir build
- - cd build
-- - cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${CI_PROJECT_DIR}/install -DGR_USE_BUNDLED_LIBRARIES=ON
-+ - cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${CI_PROJECT_DIR}/install -DGR_USE_BUNDLED_LIBRARIES=OFF
- - make
-
- windows-32bit-cross:
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 48788c30..429d3491 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -310,6 +310,7 @@ if(UNIX AND NOT APPLE)
- C_STANDARD_REQUIRED ON
- POSITION_INDEPENDENT_CODE ON
- INSTALL_RPATH "${INSTALL_RPATH}"
-+ OUTPUT_NAME GR3platform
- )
- else()
- message(WARNING "libGR3platform.so requires X11 and will not be built.")
-diff --git a/cmake/FindQhull.cmake b/cmake/FindQhull.cmake
-index ec771f97..19a54e45 100644
---- a/cmake/FindQhull.cmake
-+++ b/cmake/FindQhull.cmake
-@@ -25,7 +25,7 @@
- # If false, do not try to use Qhull.
-
- if(NOT QHULL_INCLUDE_DIR)
-- find_path(QHULL_INCLUDE_DIR qhull/qhull_a.h)
-+ find_path(QHULL_INCLUDE_DIR qhull_a.h PATH_SUFFIXES qhull libqhull)
- endif()
-
- if(NOT QHULL_LIBRARY)
-@@ -43,7 +43,7 @@ if(NOT QHULL_VERSION_STRING
- file(
- WRITE "${CMAKE_CURRENT_BINARY_DIR}/qhull_get_version.c"
- "
-- #include \"qhull/libqhull.h\"
-+ #include \"libqhull.h\"
-
- int main(void)
- {
-diff --git a/lib/gr/Makefile b/lib/gr/Makefile
-index ff2e9957..6db9b86b 100644
---- a/lib/gr/Makefile
-+++ b/lib/gr/Makefile
-@@ -14,7 +14,7 @@ UNAME := $(shell uname)
- contourf.o boundary.o
- GSDEFS =
- DEFINES = $(GSDEFS)
-- INCLUDES = -I../gks -I$(THIRDPARTYDIR)/include
-+ INCLUDES = -I../gks -I$(THIRDPARTYDIR)/include -I$(THIRDPARTYDIR)/include/qhull
- CC = cc
- CFLAGS = $(DEFINES) -O3 -Wall -fPIC $(EXTRA_CFLAGS)
- AR = ar
-diff --git a/lib/gr/delaunay.c b/lib/gr/delaunay.c
-index 9039f3f8..90ee44de 100644
---- a/lib/gr/delaunay.c
-+++ b/lib/gr/delaunay.c
-@@ -1,7 +1,7 @@
- #include <stdio.h>
- #include <stdlib.h>
-
--#include "qhull/qhull_a.h"
-+#include "qhull_a.h"
-
- #include "gr.h"
-
-diff --git a/lib/gr/makefile.mingw b/lib/gr/makefile.mingw
-index accd1dd5..6dffd64e 100644
---- a/lib/gr/makefile.mingw
-+++ b/lib/gr/makefile.mingw
-@@ -2,7 +2,7 @@ ifeq ($(strip $(THIRDPARTYDIR)),)
- override THIRDPARTYDIR = $(abspath $(CURDIR)/../../3rdparty/build)
- endif
-
-- INCLUDES = -I$(THIRDPARTYDIR)/include -I../gks -I.
-+ INCLUDES = -I$(THIRDPARTYDIR)/include -I$(THIRDPARTYDIR)/include/qhull -I../gks -I.
- CFLAGS = -DXMD_H -D_POSIX -D_WIN32_WINNT=0x0600 $(INCLUDES)
- DEFINES = -DGRDIR=\"$(GRDIR)\" -DNO_GS -DNO_X11
- JPEGLIBS = $(THIRDPARTYDIR)/lib/libjpeg.a