summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gr-framework-0.46.0.patch12
3 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 558916d60c15..bc8923362d1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gr-framework
pkgdesc = A universal framework for cross-platform visualization applications.
pkgver = 0.46.0
- pkgrel = 1
+ pkgrel = 2
url = https://gr-framework.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a19ab12313cc..d115c610a9d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="gr-framework"
pkgver="0.46.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc="A universal framework for cross-platform visualization applications."
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
url="https://gr-framework.org"
diff --git a/gr-framework-0.46.0.patch b/gr-framework-0.46.0.patch
index 073bcdeec68f..c342b20665a4 100644
--- a/gr-framework-0.46.0.patch
+++ b/gr-framework-0.46.0.patch
@@ -16,6 +16,18 @@ index 64718ef9..911dd62d 100644
- make
windows-32bit-cross:
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 48788c30..429d3491 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -310,6 +310,7 @@ if(UNIX AND NOT APPLE)
+ C_STANDARD_REQUIRED ON
+ POSITION_INDEPENDENT_CODE ON
+ INSTALL_RPATH "${INSTALL_RPATH}"
++ OUTPUT_NAME GR3platform
+ )
+ else()
+ message(WARNING "libGR3platform.so requires X11 and will not be built.")
diff --git a/cmake/FindQhull.cmake b/cmake/FindQhull.cmake
index ec771f97..19a54e45 100644
--- a/cmake/FindQhull.cmake