summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6efc72d314cd..bc0c86b8f0dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gr-hrpt
pkgdesc = HRPT Blocks from gr-noaa and others ported to GNU Radio 3.8+
- pkgver = 0.1
+ pkgver = r27.7f3bc69
pkgrel = 2
url = https://gitlab.altillimity.com/altillimity/gr-hrpt
arch = x86_64
@@ -8,10 +8,11 @@ pkgbase = gr-hrpt
makedepends = boost
makedepends = boost-libs
makedepends = cmake
+ makedepends = git
depends = gnuradio
depends = liborcus
- source = https://gitlab.altillimity.com/altillimity/gr-hrpt/-/archive/master/gr-hrpt-master.tar.gz
- sha256sums = c1e730d3717c73037b8ceee3fce10320cc06d0da8225a16591caa543bd9abf6f
+ source = gr-hrpt::git+http://gitlab.altillimity.com/altillimity/gr-hrpt.git
+ sha256sums = SKIP
pkgname = gr-hrpt
diff --git a/PKGBUILD b/PKGBUILD
index e440a80c6e22..1a073bbac3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer: Mees Luten <mees [dot] luten [at] gmail [dot] com>
# This package is build from a non-release version, going to change soon.
pkgname=gr-hrpt
-pkgver=0.1
+pkgver=r27.7f3bc69
pkgrel=2
pkgdesc="HRPT Blocks from gr-noaa and others ported to GNU Radio 3.8+"
arch=('x86_64')
url="https://gitlab.altillimity.com/altillimity/gr-hrpt"
license=('GPL3')
depends=(gnuradio liborcus)
-makedepends=(boost boost-libs cmake)
-#source=("https://gitlab.altillimity.com/altillimity/gr-hrpt/-/archive/master/gr-hrpt-master.tar.gz")
-#sha256sums=('c1e730d3717c73037b8ceee3fce10320cc06d0da8225a16591caa543bd9abf6f')
+makedepends=(boost boost-libs cmake git)
source=("$pkgname"::'git+http://gitlab.altillimity.com/altillimity/gr-hrpt.git')
sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
# rm -f -r $pkgname
# mv gr-hrpt-master $pkgname