summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8625c2a5a8c3..54db817690c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gradio
pkgdesc = A GTK3 app for finding and listening to internet radio stations
- pkgver = 7.0
+ pkgver = 7.1
pkgrel = 1
url = https://github.com/haecker-felix/gradio
arch = i686
@@ -24,12 +24,12 @@ pkgbase = gradio
depends = libgee
depends = sqlite3
depends = libsoup
- provides = gradio=7.0
+ provides = gradio=7.1
conflicts = gradio-git
conflicts = gradio-bin
options = !emptydirs
- source = https://github.com/haecker-felix/gradio/archive/v7.0.tar.gz
- sha256sums = d5cee5749491b2fcad893f1856d6f8ff90345c35e51f5ae2692c14f3de6decef
+ source = https://github.com/haecker-felix/gradio/archive/v7.1.tar.gz
+ sha256sums = b223b371bfc82831fcbf3699bb4bfa7288438d02e9351b707b1f32db7ea5f7e3
pkgname = gradio
diff --git a/PKGBUILD b/PKGBUILD
index cd537f99eb1f..9dae7d0c4bcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
pkgname=gradio
-_gitname=gradio
-pkgver=7.0
+pkgver=7.1
pkgrel=1
pkgdesc='A GTK3 app for finding and listening to internet radio stations'
arch=('i686' 'x86_64')
license=('GPL3')
url="https://github.com/haecker-felix/gradio"
-depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly'
-'gst-plugins-bad' 'gtk3' 'gobject-introspection' 'gst-plugins-base' 'gst-plugins-good' 'json-glib'
-'libgee' 'sqlite3' 'libsoup')
+depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly' 'gst-plugins-bad'
+ 'gtk3' 'gobject-introspection' 'gst-plugins-base' 'gst-plugins-good'
+ 'json-glib' 'libgee' 'sqlite3' 'libsoup')
makedepends=('gnome-common' 'meson' 'gettext' 'appstream-glib' 'vala' 'yelp-tools')
options=('!emptydirs')
-source=("https://github.com/haecker-felix/${_gitname}/archive/v${pkgver}.tar.gz")
-sha256sums=('d5cee5749491b2fcad893f1856d6f8ff90345c35e51f5ae2692c14f3de6decef')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('b223b371bfc82831fcbf3699bb4bfa7288438d02e9351b707b1f32db7ea5f7e3')
conflicts=('gradio-git' 'gradio-bin')
provides=("gradio=${pkgver}")
build() {
- cd "${srcdir}/gradio-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
meson builddir --prefix=/usr
}
package() {
- cd "${srcdir}/gradio-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
DESTDIR="${pkgdir}" ninja -C builddir install
}