summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD59
2 files changed, 40 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae00fec9299c..162d75132211 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = grandorgue-git
- pkgdesc = git-version of the Virtual Pipe Organ GrandOrgue
- pkgver = 1.0
+ pkgdesc = Virtual Pipe Organ Software
+ pkgver = 3.11.2.1.r0.g1a5832df
pkgrel = 1
- url = https://github.com/e9925248/grandorgue
+ url = https://github.com/GrandOrgue/grandorgue
arch = i686
arch = x86_64
- license = GPL
- makedepends = cmake
+ license = GPL2+
makedepends = git
+ makedepends = cmake
+ makedepends = ninja
makedepends = docbook-xsl
- makedepends = zip
- makedepends = po4a
- makedepends = gettext
- depends = fftw
+ makedepends = imagemagick
+ makedepends = yaml-cpp
+ depends = wxwidgets-gtk3
depends = wavpack
- depends = wxgtk2
- depends = alsa-lib
- depends = libglvnd
+ depends = fftw
depends = jack
- source = git+https://github.com/e9925248/grandorgue.git#branch=master
- md5sums = SKIP
+ depends = rtmidi
+ depends = rtaudio
+ depends = portaudio
+ depends = zita-convolver
+ conflicts = grandorgue
+ conflicts = grandorgue-bin
+ source = git+https://github.com/GrandOrgue/grandorgue.git
+ sha256sums = SKIP
pkgname = grandorgue-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1844db806c5f..b9fde4e3c3b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,33 @@
-# Maintainer: Klaus Fröhlich <arch@sclause.net>
-
-pkgname=grandorgue-git
-pkgver=1.0
-_branch=master
+# Maintainer: Magnus Groß, for email contact see AUR commit author email
+_pkgname=grandorgue
+pkgname="$_pkgname"-git
+pkgver=3.11.2.1.r0.g1a5832df
pkgrel=1
-pkgdesc='git-version of the Virtual Pipe Organ GrandOrgue'
+pkgdesc="Virtual Pipe Organ Software"
arch=('i686' 'x86_64')
-url='https://github.com/e9925248/grandorgue'
-license=('GPL')
-depends=(fftw
- wavpack
- wxgtk2
- alsa-lib
- libglvnd
- jack)
-makedepends=(cmake
- git
- docbook-xsl
- zip
- po4a
- gettext)
-#optdepends=('lame: MP3 export')
-#install=musescore.install
-source=("git+$url.git#branch=$_branch")
-md5sums=('SKIP')
+url="https://github.com/GrandOrgue/$_pkgname"
+license=('GPL2+')
+depends=(wxwidgets-gtk3 wavpack fftw jack rtmidi rtaudio portaudio zita-convolver)
+makedepends=(git cmake ninja docbook-xsl imagemagick yaml-cpp)
+conflicts=(grandorgue grandorgue-bin)
+source=("git+$url.git")
+sha256sums=('SKIP')
pkgver() {
- cd grandorgue
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- if [ ! -d gobuild ]; then
- mkdir gobuild
- fi
- cd gobuild
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -G "Unix Makefiles" ../grandorgue
- make
+ cd "$_pkgname"
+ cmake -B build -G Ninja -DCMAKE_INSTALL_PREFIX="/usr" -DUSE_INTERNAL_RTAUDIO=Off -DUSE_INTERNAL_PORTAUDIO=Off -DUSE_INTERNAL_ZITACONVOLVER=Off
+ cmake --build build
}
package() {
- cd gobuild
- make DESTDIR="${pkgdir}" SUFFIX="-git" LABEL="Git Build" install
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" cmake --install build
}
-