summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rwxr-xr-xgraphiql-app4
-rw-r--r--graphiql-app.desktop8
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eab3a0673154
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = graphiql-app
+ pkgdesc = A light, Electron-based wrapper around GraphiQL.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/skevy/graphiql-app
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ depends = electron
+ source = https://github.com/skevy/graphiql-app/archive/v0.6.0.tar.gz
+ source = graphiql-app.svg::https://upload.wikimedia.org/wikipedia/commons/1/17/GraphQL_Logo.svg
+ source = graphiql-app
+ source = graphiql-app.desktop
+ sha1sums = 29be20fc3e8fcdc1ac344cb6510587ced67329f6
+ sha1sums = 5291daa645b8f31fc8755e359d00fbfb21bf94db
+ sha1sums = ab93a32b54870933b1cd5d11a1112bb2318f08e4
+ sha1sums = 53949e275525271e05b6b57d2c6685c5a72f4051
+
+pkgname = graphiql-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd2b990d3b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname=graphiql-app
+pkgver=0.6.0
+pkgrel=1
+pkgdesc='A light, Electron-based wrapper around GraphiQL.'
+arch=(any)
+url='https://github.com/skevy/graphiql-app'
+license=(MIT)
+depends=(nodejs npm electron)
+source=(
+ https://github.com/skevy/$pkgname/archive/v$pkgver.tar.gz
+ graphiql-app.svg::https://upload.wikimedia.org/wikipedia/commons/1/17/GraphQL_Logo.svg
+ graphiql-app
+ graphiql-app.desktop
+)
+sha1sums=(
+ 29be20fc3e8fcdc1ac344cb6510587ced67329f6
+ 5291daa645b8f31fc8755e359d00fbfb21bf94db
+ ab93a32b54870933b1cd5d11a1112bb2318f08e4
+ 53949e275525271e05b6b57d2c6685c5a72f4051
+)
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ cp -r "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/graphiql-app"
+
+ cd "$pkgdir/opt/graphiql-app"
+
+ npm install
+ npm run build
+
+ install -Dm 755 "$srcdir/graphiql-app" "$pkgdir/usr/bin/graphiql-app"
+ install -Dm 644 "$srcdir/graphiql-app.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/graphiql-app.svg"
+ install -Dm 644 "$srcdir/graphiql-app.desktop" "$pkgdir/usr/share/applications/graphiql-app.desktop"
+}
diff --git a/graphiql-app b/graphiql-app
new file mode 100755
index 000000000000..3b577e94753d
--- /dev/null
+++ b/graphiql-app
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/graphiql-app
+npm start
diff --git a/graphiql-app.desktop b/graphiql-app.desktop
new file mode 100644
index 000000000000..00dae8b90ae4
--- /dev/null
+++ b/graphiql-app.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=GraphiQL App
+Comment=GraphiQL App
+GenericName=A light, Electron-based wrapper around GraphiQL.
+Exec=/usr/bin/graphiql-app
+Icon=graphiql-app
+Type=Application
+Categories=Network;Development;