summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58ed8ca9b26a..de3f3809592d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = graphql-playground-electron
pkgdesc = GraphQL IDE for better development workflows (GraphQL Subscriptions, interactive docs & collaboration).
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/prisma/graphql-playground
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index a570241fae79..75087e5a0911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=graphql-playground-electron
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="GraphQL IDE for better development workflows (GraphQL Subscriptions, interactive docs & collaboration)."
arch=('x86_64')
url="https://github.com/prisma/graphql-playground"
@@ -20,5 +20,9 @@ prepare() {
package() {
mv opt "$pkgdir"
mv usr "$pkgdir"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -s "/opt/GraphQL Playground/graphql-playground-electron" "${pkgdir}/usr/bin/graphql-playground-electron"
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}