summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17658d3582bc..af39bc41b89d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = graphqlmap-git
pkgdesc = scripting engine to interact with a GraphQL endpoint for pentesting purposes
- pkgver = r44.87b5626
- pkgrel = 2
+ pkgver = r63.59305d7
+ pkgrel = 1
url = https://github.com/swisskyrepo/GraphQLmap
arch = any
license = MIT
- depends = git
+ makedepends = git
+ makedepends = python-setuptools
depends = python
- depends = python-setuptools
- depends = python-argparse
depends = python-requests
+ depends = python-rl
provides = graphqlmap
conflicts = graphqlmap
options = !emptydirs
- source = git://github.com/swisskyrepo/graphqlmap.git
- source = setup.py
+ source = git+https://github.com/swisskyrepo/graphqlmap.git
sha512sums = SKIP
- sha512sums = f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346
pkgname = graphqlmap-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4791c13699d2..8ce9ecad8473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
# Maintainer: Daniel Maslowski <info@orangecms.org>
_pyname=graphqlmap
pkgname=graphqlmap-git
-pkgver=r44.87b5626
-pkgrel=2
+pkgver=r63.59305d7
+pkgrel=1
pkgdesc="scripting engine to interact with a GraphQL endpoint for pentesting purposes"
arch=('any')
url="https://github.com/swisskyrepo/GraphQLmap"
license=('MIT')
depends=(
- 'git'
'python'
- 'python-setuptools'
- 'python-argparse'
'python-requests'
+ 'python-rl'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
)
provides=("$_pyname")
conflicts=(graphqlmap)
options=(!emptydirs)
source=(
- git://github.com/swisskyrepo/$_pyname.git
- setup.py
+ git+https://github.com/swisskyrepo/$_pyname.git
)
-sha512sums=('SKIP'
- 'f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346')
+sha512sums=('SKIP')
pkgver() {
cd "$_pyname"
@@ -32,14 +33,6 @@ pkgver() {
package() {
cd "$_pyname"
- sed -i "s#from attacks#from graphqlmap.attacks#" graphqlmap.py
- sed -i "s#from utils#from graphqlmap.utils#" attacks.py
- mkdir bin
- mv graphqlmap.py bin/graphqlmap
- mkdir graphqlmap
- mv *.py graphqlmap/
- touch graphqlmap/__init__.py
- mv ../setup.py .
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm 644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
}