summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08da377d42f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = graudit
+ pkgdesc = Grep rough source code auditing tool.
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://github.com/wireghoul/graudit
+ arch = any
+ license = GPL
+ source = http://www.justanotherhacker.com/projects/graudit-1.9_src.tar.gz
+ md5sums = bc7d05f29c87fc21fa3d16da690aead1
+
+pkgname = graudit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d4220cdec5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Antonio Vázquez Blanco <antoniovazquezblanco@gmail.com>
+pkgname=graudit
+pkgver=1.9
+pkgrel=1
+pkgdesc="Grep rough source code auditing tool."
+arch=(any)
+url="https://github.com/wireghoul/graudit"
+license=('GPL')
+source=(http://www.justanotherhacker.com/projects/${pkgname}-${pkgver}_src.tar.gz)
+md5sums=('bc7d05f29c87fc21fa3d16da690aead1')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # TODO: Should only use /usr as prefix but makefile doesn't support DESTDIR...
+ ./configure --prefix "$pkgdir/usr/bin" --dbdir "$pkgdir/usr/share/graudit"
+
+ # TODO: In the future should make here...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ # TODO: Should use DESTDIR but it is not supported yet...
+ # make DESTDIR="$pkgdir/" install
+ make install
+}