summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--python2.patch8
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 112ae608e818..f900101ad2c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = greylistd
pkgdesc = Simple greylisting system for mail transport agents
- pkgver = 0.8.8.5
+ pkgver = 0.8.8.7
pkgrel = 1
- url = http://packages.debian.org/stable/mail/greylistd
+ url = https://packages.debian.org/sid/greylistd
install = greylistd.install
arch = x86_64
arch = i686
@@ -10,16 +10,16 @@ pkgbase = greylistd
depends = python2
depends = start-stop-daemon
backup = etc/greylistd/config
- source = http://ftp.debian.org/debian/pool/main/g/greylistd/greylistd_0.8.8.5.tar.xz
+ source = http://ftp.debian.org/debian/pool/main/g/greylistd/greylistd_0.8.8.7.tar.xz
source = greylistd.service
source = greylistd.tmpfiles
source = greylistd.install
source = python2.patch
- md5sums = 2a5bca5486441b0037c9e9e532fed5fc
+ md5sums = a97720a78299554f2a190f7fa6dfd39e
md5sums = ad1f516bdb732982fec38f492134d5b8
md5sums = 5c76ca975a41ef967f6a1f8bfc760446
md5sums = 7c309496b15079820b852c7140194d8c
- md5sums = ef3b973a0a07fecd673ed5f9c0df026e
+ md5sums = 6947ebf9d170801b86db013b3521e1af
pkgname = greylistd
diff --git a/PKGBUILD b/PKGBUILD
index fd0dfc909cb5..5f509925ba02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@
# Maintainer: Denis Yantarev <denis dot yantarev at gmail dot com>
pkgname=greylistd
-pkgver=0.8.8.5
+pkgver=0.8.8.7
pkgrel=1
pkgdesc="Simple greylisting system for mail transport agents"
-url="http://packages.debian.org/stable/mail/greylistd"
+url="https://packages.debian.org/sid/greylistd"
depends=('python2' 'start-stop-daemon')
source=(http://ftp.debian.org/debian/pool/main/g/greylistd/${pkgname}_${pkgver}.tar.xz
greylistd.service
greylistd.tmpfiles
greylistd.install
python2.patch)
-md5sums=('2a5bca5486441b0037c9e9e532fed5fc'
+md5sums=('a97720a78299554f2a190f7fa6dfd39e'
'ad1f516bdb732982fec38f492134d5b8'
'5c76ca975a41ef967f6a1f8bfc760446'
'7c309496b15079820b852c7140194d8c'
- 'ef3b973a0a07fecd673ed5f9c0df026e')
+ '6947ebf9d170801b86db013b3521e1af')
backup=(etc/greylistd/config)
install=greylistd.install
arch=('x86_64' 'i686')
license=('GPL')
build() {
- cd $srcdir || return 1
- patch -p0 <python2.patch || return 1
+ cd $srcdir/$pkgname-$pkgver || return 1
+ patch -p0 < ../python2.patch || return 1
}
package() {
diff --git a/python2.patch b/python2.patch
index 5e835858d627..8c6c624fa061 100644
--- a/python2.patch
+++ b/python2.patch
@@ -1,13 +1,13 @@
---- greylistd-0.8.8.5/program/greylist 2007-01-27 19:43:38.000000000 +0300
-+++ greylistd-0.8.8.5/program/greylist.new 2011-12-30 12:48:22.000000000 +0400
+--- program/greylist 2007-01-27 19:43:38.000000000 +0300
++++ program/greylist.new 2011-12-30 12:48:22.000000000 +0400
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python2
########################################################################
### FILE: greylist
### PURPOSE: Command line interface to "greylistd(8)"
---- greylistd-0.8.8.5/program/greylistd 2008-06-06 18:51:47.000000000 +0400
-+++ greylistd-0.8.8.5/program/greylistd.new 2011-12-30 12:48:28.000000000 +0400
+--- program/greylistd 2008-06-06 18:51:47.000000000 +0400
++++ program/greylistd.new 2011-12-30 12:48:28.000000000 +0400
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python2