summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e48917a65840..6ffa0405adff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 6 14:13:39 UTC 2017
+# Mon May 22 12:16:34 UTC 2017
pkgbase = grib_api
pkgdesc = A program interface for encoding and decoding GRIB messages
- pkgver = 1.20.0
- pkgrel = 2
+ pkgver = 1.21.0
+ pkgrel = 1
url = https://software.ecmwf.int/wiki/display/GRIB/Home
arch = i686
arch = x86_64
@@ -20,10 +20,11 @@ pkgbase = grib_api
optdepends = jasper: as an alternative to openjpeg
provides = grib_api
conflicts = grib_def
+ conflicts = eccodes
replaces = grib_api
replaces = grib_def
- source = http://software.ecmwf.int/wiki/download/attachments/3473437/grib_api-1.20.0-Source.tar.gz
- md5sums = 1137dfc0b8e933f2dacb1b6da7e8a5e2
+ source = http://software.ecmwf.int/wiki/download/attachments/3473437/grib_api-1.21.0-Source.tar.gz
+ md5sums = eb64c5eb72e6e90841237cba9d644016
pkgname = grib_api
diff --git a/PKGBUILD b/PKGBUILD
index c5f5ecbbbb6f..80428367b8fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Graziano Giuliani <graziano.giuliani@poste.it>
pkgname=grib_api
-pkgver=1.20.0
+pkgver=1.21.0
_attnum=3473437
-pkgrel=2
+pkgrel=1
pkgdesc="A program interface for encoding and decoding GRIB messages"
arch=('i686' 'x86_64')
url="https://software.ecmwf.int/wiki/display/GRIB/Home"
@@ -14,9 +14,9 @@ optdepends=('libaec: for compression' 'jasper: as an alternative to openjpeg')
makedepends=('gcc-fortran' 'python2' 'python2-numpy' 'cmake')
provides=('grib_api')
replaces=('grib_api' 'grib_def')
-conflicts=('grib_def')
+conflicts=('grib_def' 'eccodes')
source=(http://software.ecmwf.int/wiki/download/attachments/${_attnum}/${pkgname}-${pkgver}-Source.tar.gz)
-md5sums=('1137dfc0b8e933f2dacb1b6da7e8a5e2')
+md5sums=('eb64c5eb72e6e90841237cba9d644016')
build() {
cd "$srcdir"/${pkgname}-${pkgver}-Source
@@ -25,9 +25,7 @@ build() {
cd build
[ -x /usr/bin/aec ] && has_aec=1 || has_aec=0
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=production \
- -DCMAKE_INSTALL_DATAROOTDIR=/usr/share/$pkgname/definitions \
- -DCMAKE_INSTALL_DATADIR=/usr/share -DENABLE_AEC=$has_aec \
- -DENABLE_PNG=1 -DENABLE_GRIB_THREADS=1 \
+ -DENABLE_AEC=$has_aec -DENABLE_PNG=1 -DENABLE_GRIB_THREADS=1 \
-DOPENJPEG_INCLUDE_DIR=`pkg-config --variable=includedir libopenjpeg` \
-DPYTHON_EXECUTABLE=/usr/bin/python2 ..
make || return 1