summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
2 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 557d6fb7ba3d..0389efc92796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grinplusplus-bin
pkgdesc = A C++ Grin Node & Wallet For Linux
pkgver = 1.2.8
- pkgrel = 3
+ pkgrel = 4
url = https://grinplusplus.github.io
arch = x86_64
license = MIT
@@ -16,7 +16,6 @@ pkgbase = grinplusplus-bin
depends = zlib
depends = dbus
depends = nspr
- depends = glibc
depends = pango
depends = libxext
depends = libxfixes
@@ -29,11 +28,8 @@ pkgbase = grinplusplus-bin
depends = libxkbcommon
depends = libxrandr
depends = at-spi2-core
- depends = gcc-libs
depends = libxcb
- depends = glib2
depends = mesa
- depends = sh
provides = grinplusplus-1.2.8
conflicts = grinplusplus
source = grinplusplus-1.2.8.deb::https://github.com/GrinPlusPlus/GrinPlusPlus/releases/download/v1.2.8/GrinPlusPlus.1.2.8.deb
diff --git a/PKGBUILD b/PKGBUILD
index 9762f896e714..4ff17618fae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,48 @@
pkgname=grinplusplus-bin
_pkgname=GrinPlusPlus
pkgver=1.2.8
-pkgrel=3
+pkgrel=4
pkgdesc='A C++ Grin Node & Wallet For Linux'
arch=('x86_64')
url="https://grinplusplus.github.io"
-_githuburl="https://github.com/GrinPlusPlus/GrinPlusPlus"
+_ghurl="https://github.com/GrinPlusPlus/GrinPlusPlus"
license=('MIT')
provides=("${pkgname%-bin}-${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('gtk3' 'libxdamage' 'nss' 'libx11' 'openssl-1.1' 'alsa-lib' 'libevent' 'cairo' 'zlib' 'dbus' 'nspr' \
- 'glibc' 'pango' 'libxext' 'libxfixes' 'expat' 'libcups' 'util-linux-libs' 'gdk-pixbuf2' 'libxcomposite' 'libdrm' \
- 'libxkbcommon' 'libxrandr' 'at-spi2-core' 'gcc-libs' 'libxcb' 'glib2' 'mesa' 'sh')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${_pkgname}.${pkgver}.deb"
- "LICENSE::https://raw.githubusercontent.com/GrinPlusPlus/GrinPlusPlus/v${pkgver}/LICENSE")
+depends=(
+ 'gtk3'
+ 'libxdamage'
+ 'nss'
+ 'libx11'
+ 'openssl-1.1'
+ 'alsa-lib'
+ 'libevent'
+ 'cairo'
+ 'zlib'
+ 'dbus'
+ 'nspr'
+ 'pango'
+ 'libxext'
+ 'libxfixes'
+ 'expat'
+ 'libcups'
+ 'util-linux-libs'
+ 'gdk-pixbuf2'
+ 'libxcomposite'
+ 'libdrm'
+ 'libxkbcommon'
+ 'libxrandr'
+ 'at-spi2-core'
+ 'libxcb'
+ 'mesa'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}.${pkgver}.deb"
+ "LICENSE::https://raw.githubusercontent.com/GrinPlusPlus/GrinPlusPlus/v${pkgver}/LICENSE"
+)
sha256sums=('9d331477bec4bf78a54e0169ca862d5a269ca5e62ec27fc2897a0e6916d5621a'
'a5e9383c3cb97aa3034e5e4bf1c94a71db0c59b3a7ec1fbf198232fb9dcc5e53')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|\"/opt/${_pkgname//Plus/+}/${pkgname%-bin}\" %U|${pkgname%-bin} --no-sandbox %U|g;s|Finance|Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"