summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc76c69123d6..d2169cf94f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
pkgbase = groff-git
pkgdesc = GNU Troff. Official git trunk.
- pkgver = 1.23.0.rc1.23.g11f79d67
+ pkgver = 1.23.0.rc1.199.g79a168ad
pkgrel = 1
url = http://www.gnu.org/software/groff/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- makedepends = netpbm
- makedepends = psutils
- makedepends = ghostscript
- makedepends = libxaw
+ depends = netpbm
+ depends = psutils
+ depends = ghostscript
depends = perl
- depends = uchardet
- optdepends = ghostscript: PDF, HTML generation and other tasks.
- optdepends = netpbm: HTML generation and other tasks.
- optdepends = psutils: HTML generation and other tasks.
- optdepends = libxaw: Enable gxditvew.
+ depends = libxaw
provides = groff
conflicts = groff
source = groff-git::git://git.savannah.gnu.org/groff.git
diff --git a/PKGBUILD b/PKGBUILD
index c9289c70113f..67ed624cea57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
pkgname=groff-git
-pkgver=1.23.0.rc1.23.g11f79d67
+pkgver=1.23.0.rc1.199.g79a168ad
pkgrel=1
pkgdesc="GNU Troff. Official git trunk."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/groff/"
license=('GPL')
-depends=('perl' 'uchardet')
-makedepends=('git' 'netpbm' 'psutils' 'ghostscript' 'libxaw')
+depends=('netpbm' 'psutils' 'ghostscript' 'perl' 'libxaw')
+makedepends=('git')
conflicts=('groff')
provides=('groff')
source=(
@@ -16,12 +16,6 @@ source=(
"gnulib-git::git://git.sv.gnu.org/gnulib.git"
'site.tmac'
)
-optdepends=(
- 'ghostscript: PDF, HTML generation and other tasks.'
- 'netpbm: HTML generation and other tasks.'
- 'psutils: HTML generation and other tasks.'
- 'libxaw: Enable gxditvew.'
-)
sha256sums=('SKIP'
'SKIP'
'af59ecde597ce9f8189368a7739279a5f8a391139fe048ef6b4e493ed46e5f5f')
@@ -31,10 +25,9 @@ pkgver() {
printf "%s" "$(git describe | sed 's/\-/\./g')"
}
-
prepare() {
cd "$srcdir/$pkgname"
- sed -i.bak -e "s/\[2\.62\]/\[2\.63\]/" configure.ac
+ sed -i.bak -e "s/\[2\.62\]/\[2\.69\]/" configure.ac
./bootstrap --gnulib-srcdir="$srcdir"/gnulib-git --bootstrap-sync --no-git
}
@@ -42,13 +35,15 @@ build() {
mkdir -p "$srcdir/$pkgname"/build
cd "$srcdir/$pkgname"/build
+ export CC="clang"
+ export CXX="clang++"
local _configopts=(
--prefix=/usr
--disable-rpath
- --with-uchardet
--with-x
--with-appresdir=/usr/share/X11/app-defaults
--with-doc=yes
+ --with-uchardet=no
)
../configure "${_configopts[@]}"