summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 626e322fd2e4..fd01b64fc1f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = gromacs-4.6-complete
- pkgdesc = GROMACS is a versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
+ pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 4.6.7
pkgrel = 7
url = http://www.gromacs.org/
arch = i686
arch = x86_64
- license = GPL
- depends = gcc5
+ license = LGPL
+ makedepends = doxygen
depends = fftw
- depends = perl
depends = libxml2
depends = libsm
- depends = doxygen
+ optdepends = perl: needed for demux.pl and xplor2gmx.pl
options = !libtool
source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-4.6.7.tar.gz
source = GMXRC.bash.cmakein.patch
diff --git a/PKGBUILD b/PKGBUILD
index ff3465611f85..e8d19513aed7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,13 @@
pkgname=gromacs-4.6-complete
pkgver=4.6.7
pkgrel=7
-pkgdesc='GROMACS is a versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
+pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
-license=("GPL")
+license=("LGPL")
arch=('i686' 'x86_64')
-depends=('gcc5' 'fftw' 'perl' 'libxml2' 'libsm' 'doxygen')
+depends=('fftw' 'libxml2' 'libsm')
+optdepends=('perl: needed for demux.pl and xplor2gmx.pl')
+makedepends=('doxygen')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
@@ -20,10 +22,6 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
-#With gcc5 currently there are less errors in the tests
-# also the compilation is possible in cuda capable machines
-#export CC=gcc-5
-#export CXX=g++-5
prepare() {
cd ${srcdir}/gromacs-${pkgver}/scripts/