summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0005-10_linux-fix-grouping-of-tests.patch22
-rw-r--r--PKGBUILD12
3 files changed, 35 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81bcc942a343..e11dba4c4b65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grub
pkgdesc = GNU GRand Unified Bootloader (2)
pkgver = 2.02.beta3
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://www.gnu.org/software/grub/
install = grub.install
@@ -56,6 +56,7 @@ pkgbase = grub
source = 0002-intel-ucode.patch
source = 0003-10_linux-detect-archlinux-initramfs.patch
source = 0004-add-GRUB_COLOR_variables.patch
+ source = 0005-10_linux-fix-grouping-of-tests.patch
source = grub.default
source = grub.cfg
validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
@@ -67,6 +68,7 @@ pkgbase = grub
md5sums = ff3b8524983ce02fc48fce38f96b1a82
md5sums = ba9d27c44b677bf329e5b96933bdbde8
md5sums = e506ae4a9f9f7d1b765febfa84e10d48
+ md5sums = f1999315bbd25b4b9359919ce9b36144
md5sums = a03ffd56324520393bf574cefccb893d
md5sums = c8b9511586d57d6f2524ae7898397a46
diff --git a/0005-10_linux-fix-grouping-of-tests.patch b/0005-10_linux-fix-grouping-of-tests.patch
new file mode 100644
index 000000000000..a57b1ecf870e
--- /dev/null
+++ b/0005-10_linux-fix-grouping-of-tests.patch
@@ -0,0 +1,22 @@
+commit 082bc9f77b200eb48a5f1147163dea9c9d02d44c
+Author: Mike Gilbert <floppym@gentoo.org>
+Date: Sat Mar 5 17:30:48 2016 -0500
+
+ 10_linux: Fix grouping of tests for GRUB_DEVICE
+
+ Commit 7290bb562 causes GRUB_DISABLE_LINUX_UUID to be ignored due to
+ mixing of || and && operators. Add some parens to help with that.
+
+diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
+index 5a78513..de9044c 100644
+--- a/util/grub.d/10_linux.in
++++ b/util/grub.d/10_linux.in
+@@ -47,7 +47,7 @@ esac
+ # and mounting btrfs requires user space scanning, so force UUID in this case.
+ if [ "x${GRUB_DEVICE_UUID}" = "x" ] || [ "x${GRUB_DISABLE_LINUX_UUID}" = "xtrue" ] \
+ || ! test -e "/dev/disk/by-uuid/${GRUB_DEVICE_UUID}" \
+- || test -e "${GRUB_DEVICE}" && uses_abstraction "${GRUB_DEVICE}" lvm; then
++ || ( test -e "${GRUB_DEVICE}" && uses_abstraction "${GRUB_DEVICE}" lvm ); then
+ LINUX_ROOT_DEVICE=${GRUB_DEVICE}
+ else
+ LINUX_ROOT_DEVICE=UUID=${GRUB_DEVICE_UUID}
diff --git a/PKGBUILD b/PKGBUILD
index 23b9da3d4b88..125f0dcfac57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _UNIFONT_VER="6.3.20131217"
pkgname="grub"
pkgdesc="GNU GRand Unified Bootloader (2)"
pkgver=2.02.beta3
-pkgrel=2
+pkgrel=3
epoch=1
url="https://www.gnu.org/software/grub/"
arch=('x86_64' 'i686')
@@ -61,6 +61,7 @@ source=("grub-${_pkgver}::git+git://git.sv.gnu.org/grub.git#tag=${_GRUB_GIT_TAG}
'0002-intel-ucode.patch'
'0003-10_linux-detect-archlinux-initramfs.patch'
'0004-add-GRUB_COLOR_variables.patch'
+ '0005-10_linux-fix-grouping-of-tests.patch'
'grub.default'
'grub.cfg')
@@ -72,6 +73,7 @@ md5sums=('SKIP'
'ff3b8524983ce02fc48fce38f96b1a82'
'ba9d27c44b677bf329e5b96933bdbde8'
'e506ae4a9f9f7d1b765febfa84e10d48'
+ 'f1999315bbd25b4b9359919ce9b36144'
'a03ffd56324520393bf574cefccb893d'
'c8b9511586d57d6f2524ae7898397a46')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') #Paul Hardy
@@ -84,8 +86,10 @@ _pkgver() {
prepare() {
cd "${srcdir}/grub-${_pkgver}/"
+ msg "Patch to fix CVE-2015-8370"
# CVE-2015-8370
- patch -Np1 -i ../0001-Fix-security-issue-when-reading-username-and-passwor.patch
+ patch -Np1 -i "${srcdir}/0001-Fix-security-issue-when-reading-username-and-passwor.patch"
+ echo
msg "Patch to load Intel microcode"
patch -Np1 -i "${srcdir}/0002-intel-ucode.patch"
@@ -100,6 +104,10 @@ prepare() {
patch -Np1 -i "${srcdir}/0004-add-GRUB_COLOR_variables.patch"
echo
+ msg "Patch to fix grouping of tests for GRUB_DEVICE"
+ patch -Np1 -i "${srcdir}/0005-10_linux-fix-grouping-of-tests.patch"
+ echo
+
msg "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme"
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "${srcdir}/grub-${_pkgver}/configure.ac"