summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD317
-rw-r--r--grub-git.install20
-rw-r--r--grub.cfg139
4 files changed, 106 insertions, 414 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cccdd06c847..c37284290501 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grub-git
pkgdesc = GNU GRand Unified Bootloader (2)
- pkgver = 2.02.r164.gc79ebcd18
+ pkgver = 2.02.r241.ged087f046
pkgrel = 1
url = https://www.gnu.org/software/grub/
install = grub-git.install
@@ -8,61 +8,39 @@ pkgbase = grub-git
arch = i686
license = GPL3
makedepends = autogen
- makedepends = device-mapper
- makedepends = freetype2
- makedepends = fuse2
- makedepends = gettext
+ makedepends = bdf-unifont
makedepends = git
makedepends = help2man
makedepends = python
makedepends = rsync
- makedepends = ttf-dejavu
makedepends = texinfo
- makedepends = xz
- depends = sh
- depends = xz
- depends = gettext
+ makedepends = ttf-dejavu
+ makedepends = libusb
depends = device-mapper
+ depends = freetype2
+ depends = fuse2
+ depends = gettext
+ depends = sdl
optdepends = dosfstools: For grub-mkrescue FAT FS and EFI support
optdepends = efibootmgr: For grub-install EFI support
- optdepends = freetype2: For grub-mkfont usage
- optdepends = fuse2: For grub-mount usage
optdepends = libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
optdepends = mtools: For grub-mkrescue FAT FS support
optdepends = os-prober: To detect other OSes when generating grub.cfg in BIOS systems
+ optdepends = libusb: For grub-emu USB support
provides = grub
- provides = grub-common
- provides = grub-bios
- provides = grub-emu
- provides = grub-efi-x86_64
conflicts = grub
- conflicts = grub-common
- conflicts = grub-bios
- conflicts = grub-emu
- conflicts = grub-efi-x86_64
- conflicts = grub-legacy
- options = !makeflags
- backup = boot/grub/grub.cfg
backup = etc/default/grub
backup = etc/grub.d/40_custom
- source = grub::git+git://git.savannah.gnu.org/grub.git
- source = grub-extras::git+git://git.savannah.gnu.org/grub-extras.git
- source = https://ftp.gnu.org/gnu/unifont/unifont-10.0.06/unifont-10.0.06.bdf.gz
- source = https://ftp.gnu.org/gnu/unifont/unifont-10.0.06/unifont-10.0.06.bdf.gz.sig
+ source = grub::git://git.savannah.gnu.org/grub.git
+ source = grub-extras::git://git.savannah.gnu.org/grub-extras.git
source = 10_linux-detect-archlinux-initramfs.patch
source = add-GRUB_COLOR_variables.patch
source = grub.default
- source = grub.cfg
- validpgpkeys = E53D497F3FA42AD8C9B4D1E835A93B74E82E4209
- validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
- sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 0d81571fc519573057b7641d26a31ead55cc0b02a931589fb346a3a534c3dcc1
sha256sums = SKIP
sha256sums = b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3
sha256sums = a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29
sha256sums = 74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82
- sha256sums = c5e4f3836130c6885e9273c21f057263eba53f4b7c0e2f111f6e5f2e487a47ad
pkgname = grub-git
diff --git a/PKGBUILD b/PKGBUILD
index cdf5d9b1fef6..cc222bb6ad73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,122 +4,81 @@
# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
## "1" to enable IA32-EFI build in Arch x86_64, "0" to disable
-_IA32_EFI_IN_ARCH_X64="1"
+_ia32_efi_in_arch_x64="1"
## "1" to enable EMU build, "0" to disable
-_GRUB_EMU_BUILD="0"
+_grub_emu_build="1"
-_UNIFONT_VER="10.0.06"
+[[ "${CARCH}" == "x86_64" ]] && _target_arch="x86_64"
+[[ "${CARCH}" == "i686" ]] && _target_arch="i386"
-[[ "${CARCH}" == "x86_64" ]] && _EFI_ARCH="x86_64"
-[[ "${CARCH}" == "i686" ]] && _EFI_ARCH="i386"
-
-[[ "${CARCH}" == "x86_64" ]] && _EMU_ARCH="x86_64"
-[[ "${CARCH}" == "i686" ]] && _EMU_ARCH="i386"
+_build_platforms="i386-pc ${_target_arch}-efi"
+[[ "${CARCH}" == "x86_64" ]] && [[ "${_ia32_efi_in_arch_x64}" == "1" ]] && _build_platforms+=" i386-efi"
+[[ "${_grub_emu_build}" == "1" ]] && _build_platforms+=" ${_target_arch}-emu"
pkgname="grub-git"
-pkgver=2.02.r164.gc79ebcd18
+pkgver=2.02.r241.ged087f046
pkgrel=1
pkgdesc="GNU GRand Unified Bootloader (2)"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/grub/"
license=('GPL3')
-depends=('sh' 'xz' 'gettext' 'device-mapper')
-makedepends=('autogen' 'device-mapper' 'freetype2' 'fuse2' 'gettext' 'git'
- 'help2man' 'python' 'rsync' 'ttf-dejavu' 'texinfo' 'xz')
+depends=('device-mapper' 'freetype2' 'fuse2' 'gettext')
+makedepends=('autogen' 'bdf-unifont' 'git' 'help2man'
+ 'python' 'rsync' 'texinfo' 'ttf-dejavu')
optdepends=('dosfstools: For grub-mkrescue FAT FS and EFI support'
'efibootmgr: For grub-install EFI support'
- 'freetype2: For grub-mkfont usage'
- 'fuse2: For grub-mount usage'
'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
'mtools: For grub-mkrescue FAT FS support'
'os-prober: To detect other OSes when generating grub.cfg in BIOS systems')
-if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
- makedepends+=('libusbx' 'sdl')
- optdepends+=('libusbx: For grub-emu USB support'
- 'sdl: For grub-emu SDL support')
+if [[ "${_grub_emu_build}" == "1" ]]; then
+ depends+=('sdl')
+ makedepends+=('libusb')
+ optdepends+=('libusb: For grub-emu USB support')
fi
-provides=("${pkgname%-*}" 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
-conflicts=("${pkgname%-*}" 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy')
-backup=('boot/grub/grub.cfg'
- 'etc/default/grub'
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+backup=('etc/default/grub'
'etc/grub.d/40_custom')
-options=('!makeflags')
install="${pkgname}.install"
-source=("grub::git+git://git.savannah.gnu.org/grub.git"
- "grub-extras::git+git://git.savannah.gnu.org/grub-extras.git"
- "https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
+source=("grub::git://git.savannah.gnu.org/grub.git"
+ "grub-extras::git://git.savannah.gnu.org/grub-extras.git"
'10_linux-detect-archlinux-initramfs.patch'
'add-GRUB_COLOR_variables.patch'
- 'grub.default'
- 'grub.cfg')
+ 'grub.default')
sha256sums=('SKIP'
'SKIP'
- '0d81571fc519573057b7641d26a31ead55cc0b02a931589fb346a3a534c3dcc1'
- 'SKIP'
'b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
- '74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82'
- 'c5e4f3836130c6885e9273c21f057263eba53f4b7c0e2f111f6e5f2e487a47ad')
-validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
- '95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+ '74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82')
-_configure_options=(
- FREETYPE="pkg-config freetype2"
- BUILD_FREETYPE="pkg-config freetype2"
- --enable-mm-debug
- --enable-nls
- --enable-device-mapper
- --enable-cache-stats
- --enable-grub-mkfont
- --enable-grub-mount
- --prefix="/usr"
- --bindir="/usr/bin"
- --sbindir="/usr/bin"
- --mandir="/usr/share/man"
- --infodir="/usr/share/info"
- --datarootdir="/usr/share"
- --sysconfdir="/etc"
- --program-prefix=""
- --with-bootdir="/boot"
- --with-grubdir="grub"
- --disable-silent-rules
- --disable-werror
-)
-
prepare() {
cd grub
- msg "Patch to detect of Arch Linux initramfs images by grub-mkconfig"
- patch -Np1 -i "${srcdir}/10_linux-detect-archlinux-initramfs.patch"
+ # Patch grub-mkconfig to detect Arch Linux initramfs images.
+ patch -Np1 -i "$srcdir"/10_linux-detect-archlinux-initramfs.patch
- msg "Patch to enable GRUB_COLOR_* variables in grub-mkconfig"
- ## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
- patch -Np1 -i "${srcdir}/add-GRUB_COLOR_variables.patch"
+ # Patch to enable GRUB_COLOR_* variables in grub-mkconfig.
+ # Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
+ patch -Np1 -i "$srcdir"/add-GRUB_COLOR_variables.patch
- msg "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme"
+ # Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme.
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
- msg "Fix mkinitcpio 'rw' FS#36275"
+ # Modify grub-mkconfig behaviour to silence warnings FS#36275
sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
- msg "Fix OS naming FS#33393"
+ # Modify grub-mkconfig behaviour so automatically generated entries read 'Arch Linux' FS#33393
sed 's|GNU/Linux|Linux|' -i "util/grub.d/10_linux.in"
- msg "Pull in latest language files"
+ # Pull in latest language files
./linguas.sh
-
- msg "Remove not working langs which need LC_ALL=C.UTF-8"
- sed -e 's#en@cyrillic en@greek##g' -i "po/LINGUAS"
-
- msg "Avoid problem with unifont during compile of grub"
- # http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
- cp "${srcdir}/unifont-${_UNIFONT_VER}.bdf" "unifont.bdf"
-
- msg "Run autogen.sh"
- ./autogen.sh
+
+ # Remove lua module from grub-extras as it is incompatible with changes to grub_file_open
+ # http://git.savannah.gnu.org/cgit/grub.git/commit/?id=ca0a4f689a02c2c5a5e385f874aaaa38e151564e
+ rm -rf "$srcdir"/grub-extras/lua
}
pkgver() {
@@ -130,165 +89,57 @@ pkgver() {
)
}
-_build_grub-common_and_bios() {
- msg "Set ARCH dependent variables for bios build"
- if [[ "${CARCH}" == 'x86_64' ]]; then
- _EFIEMU="--enable-efiemu"
- else
- _EFIEMU="--disable-efiemu"
- fi
-
- msg "Copy the source for building the bios part"
- cp -r "${srcdir}/grub" "${srcdir}/grub-bios"
- cd "${srcdir}/grub-bios"
-
- msg "Add the grub-extra sources for bios build"
- install -d "${srcdir}/grub-bios/grub-extras"
- cp -r "${srcdir}/grub-extras/915resolution" "${srcdir}/grub-bios/grub-extras/915resolution"
- export GRUB_CONTRIB="${srcdir}/grub-bios/grub-extras"
-
- msg "Unset all compiler FLAGS for bios build"
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
- msg "Run ./configure for bios build"
- ./configure \
- --with-platform="pc" \
- --target="i386" \
- "${_EFIEMU}" \
- --enable-boot-time \
- "${_configure_options[@]}"
-
- msg "Run make for bios build"
- make
-}
-
-_build_grub-efi() {
- msg "Copy the source for building the ${_EFI_ARCH} efi part"
- cp -r "${srcdir}/grub" "${srcdir}/grub-efi-${_EFI_ARCH}"
- cd "${srcdir}/grub-efi-${_EFI_ARCH}"
-
- msg "Unset all compiler FLAGS for ${_EFI_ARCH} efi build"
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
- msg "Run ./configure for ${_EFI_ARCH} efi build"
- ./configure \
- --with-platform="efi" \
- --target="${_EFI_ARCH}" \
- --disable-efiemu \
- --enable-boot-time \
- "${_configure_options[@]}"
-
- msg "Run make for ${_EFI_ARCH} efi build"
- make
-}
-
-_build_grub-emu() {
- msg "Copy the source for building the emu part"
- cp -r "${srcdir}/grub" "${srcdir}/grub-emu"
- cd "${srcdir}/grub-emu"
-
- msg "Unset all compiler FLAGS for emu build"
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
- msg "Run ./configure for emu build"
- ./configure \
- --with-platform="emu" \
- --target="${_EMU_ARCH}" \
- --enable-grub-emu-usb=no \
- --enable-grub-emu-sdl=no \
- --disable-grub-emu-pci \
- "${_configure_options[@]}"
-
- msg "Run make for emu build"
- make
-}
-
build() {
- msg "Build grub bios stuff"
- _build_grub-common_and_bios
-
- msg "Build grub ${_EFI_ARCH} efi stuff"
- _build_grub-efi
-
- if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
- msg "Build grub i386 efi stuff"
- _EFI_ARCH="i386" _build_grub-efi
- fi
-
- if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
- msg "Build grub emu stuff"
- _build_grub-emu
- fi
-}
-
-_package_grub-common_and_bios() {
- cd "${srcdir}/grub-bios/"
-
- msg "Run make install for bios build"
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
-
- msg "Remove gdb debugging related files for bios build"
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/i386-pc"/{kernel.exec,gdb_grub,gmodule.pl} || true
-
- msg "Install /etc/default/grub (used by grub-mkconfig)"
- install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
-
- msg "Install grub.cfg for backup array"
- install -D -m0644 "${srcdir}/grub.cfg" "${pkgdir}/boot/grub/grub.cfg"
-}
-
-_package_grub-efi() {
- cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
-
- msg "Run make install for ${_EFI_ARCH} efi build"
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
-
- msg "Remove gdb debugging related files for ${_EFI_ARCH} efi build"
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/{kernel.exec,gdb_grub,gmodule.pl} || true
-}
-
-_package_grub-emu() {
- cd "${srcdir}/grub-emu/"
-
- msg "Run make install for emu build"
- make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
+ cd grub
+ export GRUB_CONTRIB="$srcdir"/grub-extras
+ ./autogen.sh
- msg "Remove gdb debugging related files for emu build"
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.module || true
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.image || true
- rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/{kernel.exec,gdb_grub,gmodule.pl} || true
+ # Undefined references to __stack_chk_fail
+ CFLAGS=${CFLAGS/-fstack-protector-strong}
+
+ # Undefined references to _GLOBAL_OFFSET_TABLE_
+ CFLAGS=${CFLAGS/-fno-plt}
+
+ for _arch in $_build_platforms; do
+ mkdir "$srcdir"/grub/build_"$_arch"
+ cd "$srcdir"/grub/build_"$_arch"
+
+ # Explicitly set ac_cv_header_sys_sysmacros_h
+ # https://savannah.gnu.org/bugs/index.php?55520
+ ../configure --with-platform="${_arch##*-}" \
+ --target="${_arch%%-*}" \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --sysconfdir="/etc" \
+ --enable-boot-time \
+ --enable-cache-stats \
+ --enable-device-mapper \
+ --enable-grub-mkfont \
+ --enable-grub-mount \
+ --enable-mm-debug \
+ --enable-nls \
+ --disable-silent-rules \
+ --disable-werror \
+ ac_cv_header_sys_sysmacros_h=yes
+ make
+ done
}
package() {
- msg "Package grub ${_EFI_ARCH} efi stuff"
- _package_grub-efi
-
- if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
- msg "Package grub i386 efi stuff"
- _EFI_ARCH="i386" _package_grub-efi
- fi
-
- if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
- msg "Package grub emu stuff"
- _package_grub-emu
- fi
-
- msg "Package grub bios stuff"
- _package_grub-common_and_bios
-}
+ cd grub
+
+ for _arch in $_build_platforms; do
+ cd "$srcdir"/grub/build_"$_arch"
+ make DESTDIR="$pkgdir" bashcompletiondir=/usr/share/bash-completion/completions install
+ done
+
+ # Install /etc/default/grub (used by grub-mkconfig)
+ install -D -m0644 "$srcdir"/grub.default "$pkgdir"/etc/default/grub
+
+ # Tidy up
+ find "$pkgdir"/usr/lib/grub \( -name '*.module' -o \
+ -name '*.image' -o \
+ -name 'kernel.exec' -o \
+ -name 'gdb_grub' -o \
+ -name 'gmodule.pl' \) -delete
+} \ No newline at end of file
diff --git a/grub-git.install b/grub-git.install
index cf2e4b59535f..c13ef99c77c5 100644
--- a/grub-git.install
+++ b/grub-git.install
@@ -1,15 +1,17 @@
-post_install() {
- if [ -f /boot/grub/grub.cfg.pacsave ]; then
- echo "Copying /boot/grub/grub.cfg.pacsave to /boot/grub/grub.cfg"
- install -D -m0644 /boot/grub/grub.cfg.pacsave /boot/grub/grub.cfg
+#!/bin/sh
+
+post_upgrade() {
+ # We used to package /boot/grub/grub.cfg, but there is no reason to.
+ # Remove the file from package, but move real file back in place.
+ if [ ! -f /boot/grub/grub.cfg -a -f /boot/grub/grub.cfg.pacsave ]; then
+ mv /boot/grub/grub.cfg.pacsave /boot/grub/grub.cfg
fi
+}
+post_install() {
cat << 'EOM'
-Generating grub.cfg.example config file...
-This may fail on some machines running a custom kernel.
+Generate your bootloader configuration with:
+ grub-mkconfig -o /boot/grub/grub.cfg
EOM
-
- grub-mkconfig -o /boot/grub/grub.cfg.example 2> /dev/null
- echo "done."
}
diff --git a/grub.cfg b/grub.cfg
deleted file mode 100644
index 9d9144f870d1..000000000000
--- a/grub.cfg
+++ /dev/null
@@ -1,139 +0,0 @@
-#
-# DO NOT EDIT THIS FILE
-#
-# It is automatically generated by grub-mkconfig using templates
-# from /etc/grub.d and settings from /etc/default/grub
-#
-
-### BEGIN /etc/grub.d/00_header ###
-insmod part_gpt
-insmod part_msdos
-if [ -s $prefix/grubenv ]; then
- load_env
-fi
-set default="0"
-
-if [ x"${feature_menuentry_id}" = xy ]; then
- menuentry_id_option="--id"
-else
- menuentry_id_option=""
-fi
-
-export menuentry_id_option
-
-if [ "${prev_saved_entry}" ]; then
- set saved_entry="${prev_saved_entry}"
- save_env saved_entry
- set prev_saved_entry=
- save_env prev_saved_entry
- set boot_once=true
-fi
-
-function savedefault {
- if [ -z "${boot_once}" ]; then
- saved_entry="${chosen}"
- save_env saved_entry
- fi
-}
-
-function load_video {
- if [ x$feature_all_video_module = xy ]; then
- insmod all_video
- else
- insmod efi_gop
- insmod efi_uga
- insmod ieee1275_fb
- insmod vbe
- insmod vga
- insmod video_bochs
- insmod video_cirrus
- fi
-}
-
-if [ x$feature_default_font_path = xy ] ; then
- font=unicode
-else
-insmod part_msdos
-insmod ext2
-set root='hd0,msdos5'
-if [ x$feature_platform_search_hint = xy ]; then
- search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 ad4103fa-d940-47ca-8506-301d8071d467
-else
- search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
-fi
- font="/usr/share/grub/unicode.pf2"
-fi
-
-if loadfont $font ; then
- set gfxmode=auto
- load_video
- insmod gfxterm
- set locale_dir=$prefix/locale
- set lang=en_US
- insmod gettext
-fi
-terminal_input console
-terminal_output gfxterm
-set timeout=5
-### END /etc/grub.d/00_header ###
-
-### BEGIN /etc/grub.d/10_linux ###
-menuentry 'Arch Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-ad4103fa-d940-47ca-8506-301d8071d467' {
- load_video
- set gfxpayload=keep
- insmod gzio
- insmod part_msdos
- insmod ext2
- set root='hd0,msdos5'
- if [ x$feature_platform_search_hint = xy ]; then
- search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 ad4103fa-d940-47ca-8506-301d8071d467
- else
- search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
- fi
- echo 'Loading Linux core repo kernel ...'
- linux /boot/vmlinuz-linux root=UUID=ad4103fa-d940-47ca-8506-301d8071d467 rw quiet
- echo 'Loading initial ramdisk ...'
- initrd /boot/initramfs-linux.img
-}
-menuentry 'Arch Linux, with Linux core repo kernel (Fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-fallback-ad4103fa-d940-47ca-8506-301d8071d467' {
- load_video
- set gfxpayload=keep
- insmod gzio
- insmod part_msdos
- insmod ext2
- set root='hd0,msdos5'
- if [ x$feature_platform_search_hint = xy ]; then
- search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 ad4103fa-d940-47ca-8506-301d8071d467
- else
- search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
- fi
- echo 'Loading Linux core repo kernel ...'
- linux /boot/vmlinuz-linux root=UUID=ad4103fa-d940-47ca-8506-301d8071d467 rw quiet
- echo 'Loading initial ramdisk ...'
- initrd /boot/initramfs-linux-fallback.img
-}
-
-### END /etc/grub.d/10_linux ###
-
-### BEGIN /etc/grub.d/20_linux_xen ###
-### END /etc/grub.d/20_linux_xen ###
-
-### BEGIN /etc/grub.d/20_memtest86+ ###
-### END /etc/grub.d/20_memtest86+ ###
-
-### BEGIN /etc/grub.d/30_os-prober ###
-### END /etc/grub.d/30_os-prober ###
-
-### BEGIN /etc/grub.d/40_custom ###
-# This file provides an easy way to add custom menu entries. Simply type the
-# menu entries you want to add after this comment. Be careful not to change
-# the 'exec tail' line above.
-### END /etc/grub.d/40_custom ###
-
-### BEGIN /etc/grub.d/41_custom ###
-if [ -f ${config_directory}/custom.cfg ]; then
- source ${config_directory}/custom.cfg
-elif [ -z "${config_directory}" -a -f $prefix/custom.cfg ]; then
- source $prefix/custom.cfg;
-fi
-### END /etc/grub.d/41_custom ###