summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--grub2-theme-archxion.install29
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bad651a765a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = grub2-theme-archxion
+ pkgdesc = Grub2 gfxmenu theme.
+ pkgver = 1.0
+ pkgrel = 6
+ url = https://github.com/Generator/Grub2-themes
+ install = grub2-theme-archxion.install
+ arch = any
+ license = GPLv3
+ depends = grub
+ source = https://github.com/downloads/Generator/Grub2-themes/Archxion.tar.bz2
+ md5sums = b994445c08e81c00d91c727e06053f44
+
+pkgname = grub2-theme-archxion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05e9d978e9bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: American_Jesus <american.jesus.pt AT gmail DOT com>
+
+pkgname=grub2-theme-archxion
+_pkgname=Archxion
+pkgver=1.0
+pkgrel=6
+pkgdesc="Grub2 gfxmenu theme."
+url="https://github.com/Generator/Grub2-themes"
+arch=('any')
+license=('GPLv3')
+depends=('grub')
+install=${pkgname}.install
+source=("https://github.com/downloads/Generator/Grub2-themes/$_pkgname.tar.bz2")
+md5sums=('b994445c08e81c00d91c727e06053f44')
+
+package() {
+ cd "${srcdir}"
+ rm ${srcdir}/Archxion/progress_highlight_{e,w}.png
+ find . -type f -exec install -D -m644 {} ${pkgdir}/boot/grub/themes/{} \;
+}
diff --git a/grub2-theme-archxion.install b/grub2-theme-archxion.install
new file mode 100644
index 000000000000..3e79a0b0aa48
--- /dev/null
+++ b/grub2-theme-archxion.install
@@ -0,0 +1,29 @@
+post_install() {
+ cat << _EOF
+
+==> Installation:
+==> Add theme to your /etc/default/grub: GRUB_THEME="/boot/grub/themes/Archxion/theme.txt"
+==> Preferred resolution 1024x768: GRUB_GFXMODE=1024x768
+==> Update grub:# grub-mkconfig -o /boot/grub/grub.cfg
+
+_EOF
+}
+
+pre_upgrade() {
+ checkver=$(pacman -Qs grub2-theme-archxion | head -n 1 | awk '{print $2}')
+ target=/boot/grub/themes/Archlinux
+
+ if [[ $checkver == "1.0-1" ]]; then
+ cat << _EOF
+
+==> Install target changed to /boot/grub/themes/Archxion
+==> No longer needed to copy /usr/share/grub/themes/Archxion to /boot/grub/themes/
+
+_EOF
+ # Not Working
+ #if [ -d "$target" ]; then
+ # rm -rf /boot/grub/themes/Archxion
+ #fi
+ fi
+}
+