summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
-rw-r--r--grub2-theme-vimix-git.install14
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e3974a452e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = grub2-theme-vimix-git
+ pkgdesc = Grub2 theme Vimix
+ pkgver = 20150513
+ pkgrel = 1
+ url = https://github.com/Se7endAY/grub2-theme-vimix
+ install = grub2-theme-vimix-git.install
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = grub
+ conflicts = grub2-theme-vimix
+ source = grub2-theme-vimix-git::git+https://github.com/Se7endAY/grub2-theme-vimix
+ md5sums = SKIP
+
+pkgname = grub2-theme-vimix-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..302bfbe7fe7d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+grub2-theme-vimix-git/*
+src/*
+pkg/*
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcbcc935912a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: se7enday(87635645#qq.com)
+
+pkgname=grub2-theme-vimix-git
+pkgver=20150513
+pkgrel=1
+pkgdesc="Grub2 theme Vimix"
+url="https://github.com/Se7endAY/grub2-theme-vimix"
+arch=('any')
+license=('GPLv3')
+depends=('grub')
+makedepends=('git')
+install=${pkgname}.install
+source=("${pkgname}"::"git+https://github.com/Se7endAY/grub2-theme-vimix")
+conflicts=('grub2-theme-vimix')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ find ./Vimix/ -type f -exec install -Dm644 {} \
+ "${pkgdir}/boot/grub/themes/{}" \;
+}
+
diff --git a/grub2-theme-vimix-git.install b/grub2-theme-vimix-git.install
new file mode 100644
index 000000000000..1f3f48f47847
--- /dev/null
+++ b/grub2-theme-vimix-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat << _EOF
+
+==> Author: 浣衣尘(http://tieba.baidu.com/p/3757812932)
+==> Installation:
+==> Edit /etc/default/grub: GRUB_THEME="/boot/grub/themes/Vimix/theme.txt"
+==> Update grub:# grub-mkconfig -o /boot/grub/grub.cfg
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}