summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
-rw-r--r--rungsas24
3 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b943c645d94..e06d2401ca68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# pon lut 6 18:22:59 UTC 2017
pkgbase = gsas2-svn
pkgdesc = General Structure Analysis System II - refinement for powder diffraction patterns
- pkgver = 2692
+ pkgver = 2912
pkgrel = 1
- url = https://subversion.xor.aps.anl.gov/trac/pyGSAS
+ url = https://subversion.xray.aps.anl.gov/trac/pyGSAS
arch = i686
arch = x86_64
license = unknown
@@ -15,12 +13,11 @@ pkgbase = gsas2-svn
depends = wxpython
depends = python2-opengl
depends = python2-numpy
- source = gsas2::svn+https://subversion.xor.aps.anl.gov/pyGSAS/trunk/
+ depends = gcc
+ source = gsas2::svn+https://subversion.xray.aps.anl.gov/pyGSAS/trunk/
source = GSASII.desktop
- source = rungsas2
md5sums = SKIP
md5sums = e9d06aed1866e65ce8259cfd5a31e1ce
- md5sums = c114904d9eb6130abfb83e3d23adf005
pkgname = gsas2-svn
diff --git a/PKGBUILD b/PKGBUILD
index 125aa0a80ca2..ec93ddc1db36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=gsas2-svn
_pkgname=gsas2
-pkgver=2692
+pkgver=2912
pkgrel=1
pkgdesc="General Structure Analysis System II - refinement for powder diffraction patterns"
arch=(i686 x86_64)
-url="https://subversion.xor.aps.anl.gov/trac/pyGSAS"
+url="https://subversion.xray.aps.anl.gov/trac/pyGSAS"
license=(unknown)
-depends=(python2 python2-scipy python2-matplotlib wxpython python2-opengl python2-numpy)
+depends=(python2 python2-scipy python2-matplotlib wxpython python2-opengl python2-numpy gcc)
[ "${CARCH}" = "x86_64" ] && depends=("${depends[@]}")
makedepends=(subversion)
-source=("${_pkgname}::svn+https://subversion.xor.aps.anl.gov/pyGSAS/trunk/"
- "GSASII.desktop"
- "rungsas2")
+source=("${_pkgname}::svn+https://subversion.xray.aps.anl.gov/pyGSAS/trunk/"
+ "GSASII.desktop")
md5sums=('SKIP'
- 'e9d06aed1866e65ce8259cfd5a31e1ce'
- 'c114904d9eb6130abfb83e3d23adf005')
+ 'e9d06aed1866e65ce8259cfd5a31e1ce')
pkgver() {
cd "${SRCDEST}/${_pkgname}"
@@ -42,7 +40,7 @@ package()
[ "${CARCH}" == "i686" ] && rm -rf binlinux64-2.7
[ "${CARCH}" == "x86_64" ] && rm -rf binlinux2.7
- for _dir in {binmac,binwin}{,64-}2.7-bak; do
+ for _dir in {binmac,binwin}{,64-}2.7; do
rm -rf ${_dir}
done
@@ -57,6 +55,20 @@ package()
install -m 644 -D "$srcdir/GSASII.desktop" "$pkgdir/usr/share/applications/GSASII.desktop"
#Install and link executables:
+ if [ "${CARCH}" == "i686" ]; then
+ cat <<EOF > "$srcdir/rungsas2"
+#!/bin/bash
+LD_LIBRARY_PATH="\${LD_LIBRARY_PATH}:/usr/lib/gcc/i686-pc-linux-gnu/5.4.0"
+python2 /opt/gsas2/GSASII.py
+EOF
+ else
+ cat <<EOF > "$srcdir/rungsas2"
+#!/bin/bash
+LD_LIBRARY_PATH="\${LD_LIBRARY_PATH}:/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0"
+python2 /opt/gsas2/GSASII.py
+EOF
+ fi
+
cp "$srcdir/rungsas2" "$pkgdir/opt/gsas2/${_pkgname}"
chmod +x "$pkgdir/opt/${_pkgname}/gsas2"
diff --git a/rungsas2 b/rungsas2
deleted file mode 100644
index 1687f4f36907..000000000000
--- a/rungsas2
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/bash
-
-python2 /opt/gsas2/GSASII.py
-