summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4bb4827e279..54f6579f335a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = gsc
pkgdesc = All-sky catalog of positions and magnitudes for ~19 million stars and other objects
pkgver = 1.2
- pkgrel = 3
+ pkgrel = 5
url = http://gsss.stsci.edu/Catalogs/GSC/GSC1/GSC1.htm
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = cmake
source = http://cdsarc.u-strasbg.fr/viz-bin/nph-Cat/tar.gz?bincats/GSC_1.2
source = gsc.sh
- sha256sums = bd7334acf54d3ed3cd577e7afcf895d410462dc9691135875aa099302f6544e7
+ sha256sums = SKIP
sha256sums = 59387f8ab62f582465ea97e9b586cccb5f0432f9f8158774ac66030e1bb911f8
pkgname = gsc
-
diff --git a/PKGBUILD b/PKGBUILD
index 04c1e645a65e..7b75ba1408cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=gsc
pkgver=1.2
-pkgrel=3
+pkgrel=5
pkgdesc="All-sky catalog of positions and magnitudes for ~19 million stars and other objects"
url=""http://gsss.stsci.edu/Catalogs/GSC/GSC1/GSC1.htm
license=(GPL2)
-arch=(i686 x86_64)
+arch=(any)
depends=()
makedepends=(cmake)
source=("http://cdsarc.u-strasbg.fr/viz-bin/nph-Cat/tar.gz?bincats/GSC_${pkgver}"
"gsc.sh")
-sha256sums=('bd7334acf54d3ed3cd577e7afcf895d410462dc9691135875aa099302f6544e7'
+sha256sums=('SKIP'
'59387f8ab62f582465ea97e9b586cccb5f0432f9f8158774ac66030e1bb911f8')
build() {
@@ -24,7 +24,7 @@ build() {
package() {
cd ${srcdir}
- for file in $(find N* -type f); do
+ for file in $(find [NS]* -type f); do
install -v -m 644 -D ${file} "${pkgdir}/usr/share/GSC/${file#source/}"
done
install -v -m 755 -D src/gsc.exe "${pkgdir}/usr/share/GSC/bin/gsc"