summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3f9646b70b3..03f035a74ca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,11 @@ build(){
cargo cbuild "${_cargo_opts[@]}"
}
+check() {
+ cd $_reponame-$pkgver
+ cargo ctest "${_cargo_opts[@]}" --target-dir=tests-build
+}
+
package() {
cd $_reponame-$pkgver
cargo cinstall "${_cargo_opts[@]}" --destdir="$pkgdir"