summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD66
2 files changed, 25 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3fcdfd2b06d..2213338c7a08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = gst-plugins-ugly-git
pkgdesc = GStreamer Multimedia Framework Ugly Plugins (git version)
- pkgver = 1.15.0.1.r5505.g59d43105
+ pkgver = 1.16.0.r16.g3cd445a4
pkgrel = 1
url = https://gstreamer.freedesktop.org/
- arch = i686
arch = x86_64
license = LGPL
makedepends = git
+ makedepends = meson
makedepends = python
makedepends = gtk-doc
- makedepends = autoconf-archive
depends = libdvdread
depends = libmpeg2
depends = a52dec
@@ -19,10 +18,10 @@ pkgbase = gst-plugins-ugly-git
depends = opencore-amr
depends = gstreamer-git
depends = gst-plugins-base-git
- provides = gst-plugins-ugly=1.15.0.1
+ provides = gst-plugins-ugly=1.16.0
conflicts = gst-plugins-ugly
- source = git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly.git
- source = gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common.git
+ source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git
+ source = gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4c77a76e45e8..74694c8df3d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gst-plugins-ugly-git
-_srcname=gst-plugins-ugly
-pkgver=1.15.0.1.r5505.g59d43105
+pkgver=1.16.0.r16.g3cd445a4
pkgrel=1
pkgdesc='GStreamer Multimedia Framework Ugly Plugins (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://gstreamer.freedesktop.org/'
license=('LGPL')
depends=(
@@ -16,67 +15,42 @@ depends=(
# AUR:
'gstreamer-git' 'gst-plugins-base-git'
)
-makedepends=('git' 'python' 'gtk-doc' 'autoconf-archive')
+makedepends=('git' 'meson' 'python' 'gtk-doc')
provides=("gst-plugins-ugly=${pkgver%%.r*}")
conflicts=('gst-plugins-ugly')
-source=('git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly.git'
- 'gst-common'::'git+https://anongit.freedesktop.org/git/gstreamer/common.git')
+source=('git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git'
+ 'gst-common'::'git+https://gitlab.freedesktop.org/gstreamer/common.git')
sha256sums=('SKIP'
'SKIP')
prepare() {
- cd "$_srcname"
-
+ cd gst-plugins-ugly
+
git submodule init
git config --local submodule.common.url "${srcdir}/gst-common"
git submodule update
-
- NOCONFIGURE='1' ./autogen.sh
}
pkgver() {
- cd "$_srcname"
-
- local _version
- local _revision
- local _shorthash
-
- _version="$(grep 'AC_INIT' configure.ac | sed 's/,\[http.*//;s/AC_INIT.*\],//;s/.*\[\([^]]*\)\].*/\1/g')"
- _revision="$(git rev-list --count HEAD)"
- _shorthash="$(git rev-parse --short HEAD)"
-
- printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+ cd gst-plugins-ugly
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$_srcname"
-
- ./configure \
- --prefix='/usr' \
- --sysconfdir='/etc' \
- --localstatedir='/var' \
- --libexecdir='/usr/lib' \
- --enable-shared \
- --disable-static \
- --enable-experimental \
- --enable-gtk-doc \
- --with-package-name='GStreamer Ugly Plugins (Arch Linux)' \
- --with-package-origin='http://www.archlinux.org/'
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ arch-meson gst-plugins-ugly build \
+ -D gobject-cast-checks='disabled' \
+ -D glib-asserts='disabled' \
+ -D glib-checks='disabled' \
+ -D doc='disabled' \
+ -D package-name='GStreamer Ugly Plugins (Arch Linux)' \
+ -D package-origin='https://www.archlinux.org/'
+ ninja -C build
}
check() {
- cd "$_srcname"
-
- make check
+ meson test -C build --print-errorlogs
}
package() {
- cd "$_srcname"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}