summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD87
2 files changed, 83 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4982e5ca6fac..7b7f5ddc7ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,36 @@
+# Generated by mksrcinfo v8
+# Mon Jun 19 02:55:21 UTC 2017
pkgbase = gst-plugins-ugly-git
- pkgdesc = GStreamer Multimedia Framework Ugly Plugins
- pkgver = 1.5.1.1.5184.c72abcf
+ pkgdesc = GStreamer Multimedia Framework Ugly Plugins (git version)
+ pkgver = 1.13.0.1.r5421.g6b03e61b
pkgrel = 1
- url = http://gstreamer.freedesktop.org/
+ url = https://gstreamer.freedesktop.org/
arch = i686
arch = x86_64
license = LGPL
- depends = gst-plugins-base-libs
+ makedepends = git
+ makedepends = python
+ makedepends = gtk-doc
+ makedepends = x264
+ makedepends = autoconf-archive
+ makedepends = valgrind
depends = libdvdread
depends = lame
depends = libmpeg2
depends = a52dec
- depends = libmad
depends = libsidplay
depends = libcdio
- depends = x264
+ depends = libx264
+ depends = libx264-all
depends = opencore-amr
- provides = gst-plugins-ugly=1.5.1.1.5184.c72abcf
+ depends = mpg123
+ depends = gstreamer-git
+ depends = gst-plugins-base-git
+ provides = gst-plugins-ugly=1.13.0.1
conflicts = gst-plugins-ugly
- options = !libtool
- options = !emptydirs
- source = git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly
+ source = gst-plugins-ugly-git::git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly
+ source = submodule-gst-common::git://anongit.freedesktop.org/gstreamer/common
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = gst-plugins-ugly-git
diff --git a/PKGBUILD b/PKGBUILD
index 1beed9cdcf80..387cdaacfb5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,79 @@
-# $Id: PKGBUILD 180531 2013-03-22 19:24:55Z heftig $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gst-plugins-ugly-git
-pkgver=1.5.1.1.5184.c72abcf
+pkgver=1.13.0.1.r5421.g6b03e61b
pkgrel=1
-pkgdesc="GStreamer Multimedia Framework Ugly Plugins"
+pkgdesc='GStreamer Multimedia Framework Ugly Plugins (git version)'
arch=('i686' 'x86_64')
+url='https://gstreamer.freedesktop.org/'
license=('LGPL')
-provides=('gst-plugins-ugly='$pkgver)
+depends=(
+ # official repositories:
+ 'libdvdread' 'lame' 'libmpeg2' 'a52dec' 'libsidplay' 'libcdio'
+ 'libx264' 'libx264-all' 'opencore-amr' 'mpg123'
+ # AUR:
+ 'gstreamer-git' 'gst-plugins-base-git'
+)
+makedepends=('git' 'python' 'gtk-doc' 'x264' 'autoconf-archive' 'valgrind')
+provides=("gst-plugins-ugly=${pkgver%%.r*}")
conflicts=('gst-plugins-ugly')
-url="http://gstreamer.freedesktop.org/"
-depends=('gst-plugins-base-libs' 'libdvdread' 'lame' 'libmpeg2' 'a52dec' 'libmad' 'libsidplay' 'libcdio' 'x264' 'opencore-amr')
-options=(!libtool !emptydirs)
+source=(
+ "$pkgname"::'git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly'
+ 'submodule-gst-common'::'git://anongit.freedesktop.org/gstreamer/common'
+)
+sha256sums=('SKIP'
+ 'SKIP')
-source='git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly'
-sha256sums=('SKIP')
-
-_gitname='gst-plugins-ugly'
+prepare() {
+ cd "$pkgname"
+
+ git submodule init
+ git config --local submodule.common.url "${srcdir}/submodule-gst-common"
+ git submodule update
+}
pkgver() {
- cd $_gitname
- version=$(grep AC_INIT configure.ac | sed 's/AC_INIT(\[GStreamer Ugly Plug-ins\],\[//' | sed 's/\],\[http:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=GStreamer\],\[gst-plugins-ugly\])//')
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
-
- echo $version.$revision.$hash
+ cd "$pkgname"
+
+ local _version="$(grep 'AC_INIT' configure.ac | sed 's/,\[http.*//;s/AC_INIT.*\],//;s/.*\[\([^]]*\)\].*/\1/g')"
+ local _revision="$(git rev-list --count HEAD)"
+ local _shorthash="$(git rev-parse --short HEAD)"
+
+ printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd $_gitname
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental
- make
+ cd "$pkgname"
+
+ NOCONFIGURE=1 ./autogen.sh
+
+ ./configure \
+ --prefix='/usr' \
+ --sysconfdir='/etc' \
+ --localstatedir='/var' \
+ --libexecdir='/usr/lib' \
+ --enable-shared \
+ --disable-static \
+ --enable-experimental \
+ --enable-gtk-doc \
+ --with-package-name='GStreamer Ugly Plugins (Arch Linux)' \
+ --with-package-origin='http://www.archlinux.org/' \
+ --with-x264-libraries='/usr/lib/x264/libx264-8bit.so:/usr/lib/x264/libx264-10bit.so'
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
}
+# uncomment this block to enable checks
+#check() {
+# cd "$pkgname"
+# make check
+#}
+
package() {
- cd $_gitname
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
}