summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD60
2 files changed, 33 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index add17eb28282..d3fcdfd2b06d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gst-plugins-ugly-git
pkgdesc = GStreamer Multimedia Framework Ugly Plugins (git version)
- pkgver = 1.15.0.1.r5492.gc5cddfce
+ pkgver = 1.15.0.1.r5505.g59d43105
pkgrel = 1
url = https://gstreamer.freedesktop.org/
arch = i686
@@ -9,25 +9,20 @@ pkgbase = gst-plugins-ugly-git
makedepends = git
makedepends = python
makedepends = gtk-doc
- makedepends = x264
makedepends = autoconf-archive
- makedepends = valgrind
depends = libdvdread
- depends = lame
depends = libmpeg2
depends = a52dec
depends = libsidplay
depends = libcdio
- depends = libx264
- depends = libx264-all
+ depends = x264
depends = opencore-amr
- depends = mpg123
depends = gstreamer-git
depends = gst-plugins-base-git
provides = gst-plugins-ugly=1.15.0.1
conflicts = gst-plugins-ugly
- source = gst-plugins-ugly-git::git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly
- source = submodule-gst-common::git://anongit.freedesktop.org/gstreamer/common
+ source = git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly.git
+ source = gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 402b62a184ea..4c77a76e45e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gst-plugins-ugly-git
-pkgver=1.15.0.1.r5492.gc5cddfce
+_srcname=gst-plugins-ugly
+pkgver=1.15.0.1.r5505.g59d43105
pkgrel=1
pkgdesc='GStreamer Multimedia Framework Ugly Plugins (git version)'
arch=('i686' 'x86_64')
@@ -10,48 +11,45 @@ url='https://gstreamer.freedesktop.org/'
license=('LGPL')
depends=(
# official repositories:
- 'libdvdread' 'lame' 'libmpeg2' 'a52dec' 'libsidplay' 'libcdio'
- 'libx264' 'libx264-all' 'opencore-amr' 'mpg123'
+ 'libdvdread' 'libmpeg2' 'a52dec' 'libsidplay' 'libcdio'
+ 'x264' 'opencore-amr'
# AUR:
'gstreamer-git' 'gst-plugins-base-git'
)
-makedepends=('git' 'python' 'gtk-doc' 'x264' 'autoconf-archive' 'valgrind')
+makedepends=('git' 'python' 'gtk-doc' 'autoconf-archive')
provides=("gst-plugins-ugly=${pkgver%%.r*}")
conflicts=('gst-plugins-ugly')
-source=(
- "$pkgname"::'git://anongit.freedesktop.org/gstreamer/gst-plugins-ugly'
- 'submodule-gst-common'::'git://anongit.freedesktop.org/gstreamer/common'
-)
+source=('git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly.git'
+ 'gst-common'::'git+https://anongit.freedesktop.org/git/gstreamer/common.git')
sha256sums=('SKIP'
'SKIP')
prepare() {
- cd "$pkgname"
+ cd "$_srcname"
git submodule init
- git config --local submodule.common.url "${srcdir}/submodule-gst-common"
+ git config --local submodule.common.url "${srcdir}/gst-common"
git submodule update
+
+ NOCONFIGURE='1' ./autogen.sh
}
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
- local _version="$(grep 'AC_INIT' configure.ac | sed 's/,\[http.*//;s/AC_INIT.*\],//;s/.*\[\([^]]*\)\].*/\1/g')"
- local _revision="$(git rev-list --count HEAD)"
- local _shorthash="$(git rev-parse --short HEAD)"
+ local _version
+ local _revision
+ local _shorthash
+
+ _version="$(grep 'AC_INIT' configure.ac | sed 's/,\[http.*//;s/AC_INIT.*\],//;s/.*\[\([^]]*\)\].*/\1/g')"
+ _revision="$(git rev-list --count HEAD)"
+ _shorthash="$(git rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd "$pkgname"
-
- NOCONFIGURE=1 ./autogen.sh
-
- sed -i '/CFLAGS="$CFLAGS/s|-Werror||' configure
- sed -i '/ERROR_CFLAGS="$ERROR_CFLAGS/s|-Werror||' configure
- sed -i '/CPPFLAGS="$CPPFLAGS/s|-Werror||' configure
- sed -i '/ERROR_CXXFLAGS="$ERROR_CXXFLAGS/s|-Werror||' configure
+ cd "$_srcname"
./configure \
--prefix='/usr' \
@@ -63,8 +61,7 @@ build() {
--enable-experimental \
--enable-gtk-doc \
--with-package-name='GStreamer Ugly Plugins (Arch Linux)' \
- --with-package-origin='http://www.archlinux.org/' \
- --with-x264-libraries='/usr/lib/x264/libx264-8bit.so:/usr/lib/x264/libx264-10bit.so'
+ --with-package-origin='http://www.archlinux.org/'
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -72,13 +69,14 @@ build() {
make
}
-# uncomment this block to enable checks
-#check() {
-# cd "$pkgname"
-# make check
-#}
+check() {
+ cd "$_srcname"
+
+ make check
+}
package() {
- cd "$pkgname"
+ cd "$_srcname"
+
make DESTDIR="$pkgdir" install
}