summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
-rw-r--r--bison3.patch31
-rw-r--r--tests-remove-silly-test_fail_abstract_new-check.patch60
4 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38a7f41b69b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gstreamer0.10
+ pkgdesc = GStreamer Multimedia Framework
+ pkgver = 0.10.36
+ pkgrel = 4
+ url = http://gstreamer.com
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = pkgconfig
+ makedepends = gobject-introspection
+ makedepends = git
+ depends = libxml2
+ depends = glib2
+ source = git://anongit.freedesktop.org/gstreamer-sdk/gstreamer#commit=3ddc31eaa18c3be1613e43430eca78a3e445639e
+ source = tests-remove-silly-test_fail_abstract_new-check.patch
+ source = bison3.patch
+ sha256sums = SKIP
+ sha256sums = d3d3f4f04453831fdb4244bfe174a38c4e6f9f4da5c8c9050dcfa1a6097aad52
+ sha256sums = ed154e280abf59b24d98a8ab0fe868b449b26aa61f7ae3813fab8ac615fcaefa
+
+pkgname = gstreamer0.10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..084a17703057
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer Yurii Kolesnykov <yurikoles@gmail.com>
+# Credit: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gstreamer0.10
+pkgver=0.10.36
+pkgrel=4
+pkgdesc="GStreamer Multimedia Framework"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://gstreamer.com"
+depends=('libxml2' 'glib2')
+makedepends=('intltool' 'pkgconfig' 'gobject-introspection' 'git')
+source=("git://anongit.freedesktop.org/gstreamer-sdk/gstreamer#commit=3ddc31eaa18c3be1613e43430eca78a3e445639e"
+ tests-remove-silly-test_fail_abstract_new-check.patch
+ bison3.patch)
+sha256sums=('SKIP'
+ 'd3d3f4f04453831fdb4244bfe174a38c4e6f9f4da5c8c9050dcfa1a6097aad52'
+ 'ed154e280abf59b24d98a8ab0fe868b449b26aa61f7ae3813fab8ac615fcaefa')
+
+prepare() {
+ cd gstreamer
+ patch -Np1 -i ../tests-remove-silly-test_fail_abstract_new-check.patch
+ patch -Np1 -i ../bison3.patch
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
+}
+build() {
+ cd gstreamer
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
+ --with-package-name="GStreamer (Archlinux)" \
+ --with-package-origin="http://www.archlinux.org/" \
+ --disable-gtk-doc --disable-static
+ make
+}
+
+check() {
+ cd gstreamer
+ make check
+}
+
+package() {
+ cd gstreamer
+ make DESTDIR="${pkgdir}" install
+
+ #Remove unversioned gst-* binaries to get rid of conflicts
+ cd "${pkgdir}/usr/bin"
+ for bins in `ls *-0.10`; do
+ rm -f ${bins/-0.10/}
+ done
+}
diff --git a/bison3.patch b/bison3.patch
new file mode 100644
index 000000000000..4f4f5211166e
--- /dev/null
+++ b/bison3.patch
@@ -0,0 +1,31 @@
+From bd2a01cfe222367493a71f3269f12250c8972db0 Mon Sep 17 00:00:00 2001
+From: Kerrick Staley <kerrick@kerrickstaley.com>
+Date: Wed, 21 Aug 2013 06:59:29 +0000
+Subject: parse: make grammar.y work with Bison 3
+
+YYLEX_PARAM is no longer supported in Bison 3.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=706462
+---
+diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
+index 8a9019c..f533389 100644
+--- a/gst/parse/grammar.y
++++ b/gst/parse/grammar.y
+@@ -26,7 +26,6 @@
+ */
+
+ #define YYERROR_VERBOSE 1
+-#define YYLEX_PARAM scanner
+
+ #define YYENABLE_NLS 0
+
+@@ -659,6 +658,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
+ %right '.'
+ %left '!' '='
+
++%lex-param { void *scanner }
+ %parse-param { void *scanner }
+ %parse-param { graph_t *graph }
+ %pure-parser
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/tests-remove-silly-test_fail_abstract_new-check.patch b/tests-remove-silly-test_fail_abstract_new-check.patch
new file mode 100644
index 000000000000..7524e8feaf0f
--- /dev/null
+++ b/tests-remove-silly-test_fail_abstract_new-check.patch
@@ -0,0 +1,60 @@
+From 5bff3ba949d2ac0a9946c1240e6d4a5bb53fda99 Mon Sep 17 00:00:00 2001
+From: Tim-Philipp Müller <tim.muller@collabora.co.uk>
+Date: Wed, 08 Aug 2012 13:49:23 +0000
+Subject: tests: remove silly test_fail_abstract_new check
+
+Our check would make sure that GLib segfaults when
+someone tries to instantiate an abstract type, which
+is an extremely useful thing to check for.
+
+In newer GLibs this is fixed and we get an abort with
+a g_error() now it seems, so let's just remove this
+check entirely.
+---
+(limited to 'tests/check/gst/gstobject.c')
+
+diff --git a/tests/check/gst/gstobject.c b/tests/check/gst/gstobject.c
+index 6f7ccb8..ce2ed3e 100644
+--- a/tests/check/gst/gstobject.c
++++ b/tests/check/gst/gstobject.c
+@@ -72,19 +72,6 @@ gst_fake_object_get_type (void)
+ return fake_object_type;
+ }
+
+-#ifndef HAVE_OSX
+-/* g_object_new on abstract GstObject should fail */
+-GST_START_TEST (test_fail_abstract_new)
+-{
+- GstObject *object;
+-
+- ASSERT_CRITICAL (object = g_object_new (gst_object_get_type (), NULL));
+- fail_unless (object == NULL, "Created an instance of abstract GstObject");
+-}
+-
+-GST_END_TEST;
+-#endif
+-
+ /* g_object_new on GstFakeObject should succeed */
+ GST_START_TEST (test_fake_object_new)
+ {
+@@ -529,18 +516,6 @@ gst_object_suite (void)
+ tcase_add_test (tc_chain, test_fake_object_has_ancestor);
+ //tcase_add_checked_fixture (tc_chain, setup, teardown);
+
+- /* FIXME: GLib shouldn't crash here, but issue a warning and return a NULL
+- * object, or at least g_error() and then abort properly ... (tpm) */
+-#ifndef HAVE_OSX
+- /* Disabled for OS/X because a) it's a pretty silly test anyway and
+- * b) different OS/X versions raise different signals and it isn't worth
+- * the effort to try and detect which one should be producing which
+- */
+- /* SEGV tests go last so we can debug the others */
+- if (g_getenv ("CK_FORK") == NULL || strcmp (g_getenv ("CK_FORK"), "no") != 0)
+- tcase_add_test_raise_signal (tc_chain, test_fail_abstract_new, SIGSEGV);
+-#endif
+-
+ return s;
+ }
+
+--
+cgit v0.9.0.2-2-gbebe