summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--taglib.patch31
3 files changed, 40 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07abb272e496..89f394b0f1cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gstreamer0.10-good
pkgver = 0.10.31
- pkgrel = 29
+ pkgrel = 30
url = https://github.com/triceratops1/gstreamer0
arch = i686
arch = x86_64
@@ -33,9 +33,11 @@ pkgbase = gstreamer0.10-good
source = git+https://gitlab.com/gstreamer-sdk/gst-plugins-good.git#commit=e28fd8886f05bb51c147f871f3a1db2fc2b735a9
source = test-rtp-payloading.patch
source = souptest.patch
+ source = taglib.patch
sha256sums = SKIP
sha256sums = c2f7f07f9bf5ca3afddc81d0a44665d2d54b1e9aea0ef1b25d219cf34bf7bb29
sha256sums = 3a74492c3d2939efabe7e22211c2350084e0a8cc3af23f553130f1e774c5f1e1
+ sha256sums = 3acce9359466537695ea15d9f4e61165c092e98202fc1eaf4bbab0e62ff315ca
pkgname = gstreamer0.10-good
pkgdesc = GStreamer Multimedia Framework Good plugin libraries
@@ -104,4 +106,3 @@ pkgname = gstreamer0.10-good-plugins
replaces = gstreamer0.10-dv
replaces = gstreamer0.10-soup
replaces = gstreamer0.10-pulse
-
diff --git a/PKGBUILD b/PKGBUILD
index ee868ec39d8d..f74526b66f1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=gstreamer0.10-good
_pkgname=gst-plugins-good
pkgname=('gstreamer0.10-good' 'gstreamer0.10-good-plugins')
pkgver=0.10.31
-pkgrel=29
+pkgrel=30
arch=('i686' 'x86_64' 'armv7h')
license=('LGPL')
makedepends=('intltool' 'pkgconfig' 'gstreamer0.10-base>=0.10.36-3' 'libavc1394' 'libiec61883' 'aalib' 'libshout' 'libdv' 'flac' 'gconf' 'wavpack' 'taglib' 'libsoup' 'v4l-utils' 'libcaca' 'bzip2' 'gdk-pixbuf2' 'libpulse' 'jack' 'git' 'cairo' 'libgudev' 'python')
@@ -13,10 +13,12 @@ url="https://github.com/triceratops1/gstreamer0"
options=(!emptydirs)
source=("git+https://gitlab.com/gstreamer-sdk/$_pkgname.git#commit=e28fd8886f05bb51c147f871f3a1db2fc2b735a9"
'test-rtp-payloading.patch'
- 'souptest.patch')
+ 'souptest.patch'
+ 'taglib.patch')
sha256sums=('SKIP'
'c2f7f07f9bf5ca3afddc81d0a44665d2d54b1e9aea0ef1b25d219cf34bf7bb29'
- '3a74492c3d2939efabe7e22211c2350084e0a8cc3af23f553130f1e774c5f1e1')
+ '3a74492c3d2939efabe7e22211c2350084e0a8cc3af23f553130f1e774c5f1e1'
+ '3acce9359466537695ea15d9f4e61165c092e98202fc1eaf4bbab0e62ff315ca')
prepare() {
cd $_pkgname
@@ -26,6 +28,7 @@ prepare() {
patch -Np1 -i ../test-rtp-payloading.patch
patch -Np1 -i ../souptest.patch
+ patch -Np1 -i ../taglib.patch
}
build() {
diff --git a/taglib.patch b/taglib.patch
new file mode 100644
index 000000000000..3662b7d647d6
--- /dev/null
+++ b/taglib.patch
@@ -0,0 +1,31 @@
+--- a/ext/taglib/gstid3v2mux.cc 2024-02-27 05:56:34.025810071 +0300
++++ b/ext/taglib/gstid3v2mux.cc 2024-02-27 05:51:40.297482458 +0300
+@@ -381,7 +381,13 @@
+ GST_DEBUG ("Injecting ID3v2.%u frame %u/%u of length %u and type %"
+ GST_PTR_FORMAT, version, i, num_tags, GST_BUFFER_SIZE (buf), s);
+
++#if TAGLIB_MAJOR_VERSION > 1 || (TAGLIB_MAJOR_VERSION == 1 && TAGLIB_MINOR_VERSION >= 5)
++ ID3v2::Header header;
++ header.setMajorVersion (version);
++ frame = factory->createFrame (bytes, &header);
++#else
+ frame = factory->createFrame (bytes, (TagLib::uint) version);
++#endif
+ if (frame)
+ id3v2tag->addFrame (frame);
+ }
+@@ -546,7 +552,14 @@
+
+ g_free (data);
+
++#if TAGLIB_MAJOR_VERSION > 1 || (TAGLIB_MAJOR_VERSION == 1 && TAGLIB_MINOR_VERSION >= 5)
++ ID3v2::Header header;
++ header.setMajorVersion (4);
++ frame = factory->createFrame (bytes, &header);
++#else
+ frame = factory->createFrame (bytes, (TagLib::uint) 4);
++#endif
++
+ if (frame) {
+ id3v2tag->addFrame (frame);
+