summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD34
3 files changed, 23 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7395600e0f32..72d2f1b4ac75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,12 @@
-# Generated by mksrcinfo v8
-# Thu Dec 8 08:52:23 UTC 2016
pkgbase = gti
pkgdesc = A silly git launcher
- pkgver = 1.3.0
+ pkgver = 1.8.0
pkgrel = 1
- url = http://r-wos.org/hacks/gti
- arch = i686
+ url = https://r-wos.org/hacks/gti
arch = x86_64
license = custom
- source = https://github.com/rwos/gti/tarball/v1.3.0
- source = LICENSE
- md5sums = 0d8e4206fda5a343af7a1c530e7bfc73
- md5sums = 28c2baebd9f1dbe5498bae7ca90c005f
+ depends = git
+ source = https://github.com/rwos/gti/archive/v1.8.0.tar.gz
+ sha256sums = 65339ee1d52dede5e862b30582b2adf8aff2113cd6b5ece91775e1510b24ffb9
pkgname = gti
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 6b29adc47370..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,8 +0,0 @@
-Copyright 2012 by Richard Wossal richard@r-wos.org
-
-Permission to use, copy, modify, distribute, and sell this software and its
-documentation for any purpose is hereby granted without fee, provided that the
-above copyright notice appear in all copies and that both that copyright notice
-and this permission notice appear in supporting documentation. No
-representations are made about the suitability of this software for any
-purpose. It is provided "as is" without express or implied warranty.
diff --git a/PKGBUILD b/PKGBUILD
index 5f8d27b8cd17..d2508d22a0a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contributor: Severin Glöckner <severin.gloeckner@imn.htwk-leipzig.de>
pkgname=gti
-pkgver=1.3.0
-_commit="530a7ff"
+pkgver=1.8.0
pkgrel=1
pkgdesc="A silly git launcher"
-arch=('i686' 'x86_64')
-url="http://r-wos.org/hacks/gti"
+arch=('x86_64')
+url="https://r-wos.org/hacks/gti"
license=('custom')
-source=("https://github.com/rwos/gti/tarball/v$pkgver"
- 'LICENSE')
-md5sums=('0d8e4206fda5a343af7a1c530e7bfc73'
- '28c2baebd9f1dbe5498bae7ca90c005f')
+depends=('git')
+source=("https://github.com/rwos/gti/archive/v$pkgver.tar.gz")
+sha256sums=('65339ee1d52dede5e862b30582b2adf8aff2113cd6b5ece91775e1510b24ffb9')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed '/Copyright/,$! d' README.md > "$srcdir"/LICENSE
+ sed -i "s/=install/=install -D/" Makefile
+}
build() {
- cd "$srcdir/rwos-gti-${_commit}"
+ cd "$srcdir/$pkgname-$pkgver"
make
}
package() {
- cd "$srcdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd "rwos-gti-${_commit}"
- install -Dm755 gti "$pkgdir/usr/bin/gti"
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: