summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8011f49ad9c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Apr 10 12:03:10 UTC 2016
+pkgbase = gtk-arc-flatabulous-theme-git
+ pkgdesc = Arc theme with Flatabulous window controls.
+ pkgver = 510.cf62cb0
+ pkgrel = 1
+ url = https://github.com/andreisergiu98/arc-flatabulous-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = pkg-config
+ depends = gtk3
+ depends = gtk-engine-murrine
+ depends = gnome-themes-standard
+ source = arc-flatabulous-theme::git+https://github.com/andreisergiu98/arc-flatabulous-theme
+ sha256sums = SKIP
+
+pkgname = gtk-arc-flatabulous-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15c1fd921099
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Orestis Floros <orestisf1993@gmail.com>
+
+pkgname=gtk-arc-flatabulous-theme-git
+_pkgname=arc-flatabulous-theme
+pkgver=510.cf62cb0
+pkgrel=1
+pkgdesc="Arc theme with Flatabulous window controls."
+arch=('any')
+url="https://github.com/andreisergiu98/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine' 'gnome-themes-standard')
+makedepends=('git' 'autoconf' 'automake' 'pkg-config' )
+source=(${_pkgname}::"git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}