summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6924055a8cc..f401a2af540b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk-arc-flatabulous-theme-git
pkgdesc = Arc theme with Flatabulous window controls.
- pkgver = 709.1b1b7c9
+ pkgver = r709.1b1b7c9
pkgrel = 1
url = https://github.com/andreisergiu98/arc-flatabulous-theme
arch = any
@@ -10,7 +10,7 @@ pkgbase = gtk-arc-flatabulous-theme-git
optdepends = gtk-engine-murrine: for gtk2 themes
optdepends = gnome-themes-standard: for gtk2 themes
optdepends = arc-icon-theme: recommended icon theme
- source = arc-flatabulous-theme::git+https://github.com/andreisergiu98/arc-flatabulous-theme
+ source = git+https://github.com/andreisergiu98/arc-flatabulous-theme
sha256sums = SKIP
pkgname = gtk-arc-flatabulous-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index efbe9fab7505..0ce0a03fd650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gtk-arc-flatabulous-theme-git
_pkgname=arc-flatabulous-theme
-pkgver=709.1b1b7c9
+pkgver=r709.1b1b7c9
pkgrel=1
pkgdesc="Arc theme with Flatabulous window controls."
arch=('any')
@@ -12,18 +12,25 @@ license=('GPL3')
makedepends=('git' 'gtk3')
optdepends=('gtk-engine-murrine: for gtk2 themes'
'gnome-themes-standard: for gtk2 themes'
- 'arc-icon-theme: recommended icon theme')
-source=("${_pkgname}"::"git+${url}")
+ 'arc-icon-theme: recommended icon theme'
+ 'gtk3: for gtk3 themes'
+ )
+source=("git+${url}")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -fi
}
build() {
cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix=/usr
+ ./configure --prefix=/usr
}
package() {