summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--newer-automakes.patch21
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a1c303f6d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gtk-engine-murrine-git
+ pkgdesc = The marvelous gtk2 cairo engine (development version)
+ pkgver = 0.98.2.r406.2032a9b
+ pkgrel = 1
+ url = http://cimitan.com/murrine/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = intltool
+ depends = gtk2
+ provides = gtk-engine-murrine
+ conflicts = gtk-engine-murrine
+ source = gtk-engine-murrine::git+https://git.gnome.org/browse/murrine
+ source = newer-automakes.patch
+ sha256sums = SKIP
+ sha256sums = f36037693603ca450a8bc7e2c0ba7269af18640123b87fc6dd2eb11b3e423be3
+
+pkgname = gtk-engine-murrine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..870d27f410a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
+# Contributor: zhuqin <zhuqin83@gmail.com>
+
+pkgname=gtk-engine-murrine-git
+pkgver=0.98.2.r406.2032a9b
+pkgrel=1
+pkgdesc="The marvelous gtk2 cairo engine (development version)"
+arch=('i686' 'x86_64')
+url="http://cimitan.com/murrine/"
+license=('LGPL')
+depends=('gtk2')
+makedepends=('git' 'intltool')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+source=("${pkgname%-*}"::"git+https://git.gnome.org/browse/murrine"
+ "newer-automakes.patch")
+sha256sums=('SKIP'
+ 'f36037693603ca450a8bc7e2c0ba7269af18640123b87fc6dd2eb11b3e423be3')
+
+pkgver() {
+ cd "${pkgname%-*}"
+
+ _ver=$(grep AC_INIT configure.ac | sed 's/[^0-9.]//g')
+ _rev=$(git rev-list --count HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "$_ver.r%s.%s" "$_rev" "$_hash"
+}
+
+prepare() {
+ cd "${pkgname%-*}"
+
+ patch -Nup1 < ../newer-automakes.patch
+}
+
+build() {
+ cd "${pkgname%-*}"
+
+ ./autogen.sh --prefix=/usr --enable-animation --enable-animationrtl
+ make
+}
+
+package() {
+ make -C "${pkgname%-*}" DESTDIR="$pkgdir" install
+}
diff --git a/newer-automakes.patch b/newer-automakes.patch
new file mode 100644
index 000000000000..ffc634ad74fa
--- /dev/null
+++ b/newer-automakes.patch
@@ -0,0 +1,21 @@
+diff -Naur murrine.old/autogen.sh murrine/autogen.sh
+--- murrine.old/autogen.sh 2014-10-10 19:42:40.369018392 +0200
++++ murrine/autogen.sh 2014-10-10 19:43:37.899773129 +0200
+@@ -16,7 +16,16 @@
+ DIE=1
+ }
+
+-if automake-1.11 --version < /dev/null > /dev/null 2>&1 ; then
++if automake-1.14 --version < /dev/null > /dev/null 2>&1 ; then
++ AUTOMAKE=automake-1.14
++ ACLOCAL=aclocal-1.14
++elif automake-1.13 --version < /dev/null > /dev/null 2>&1 ; then
++ AUTOMAKE=automake-1.13
++ ACLOCAL=aclocal-1.13
++elif automake-1.12 --version < /dev/null > /dev/null 2>&1 ; then
++ AUTOMAKE=automake-1.12
++ ACLOCAL=aclocal-1.12
++elif automake-1.11 --version < /dev/null > /dev/null 2>&1 ; then
+ AUTOMAKE=automake-1.11
+ ACLOCAL=aclocal-1.11
+ elif automake-1.10 --version < /dev/null > /dev/null 2>&1 ; then