summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--28f9cb813016803026a0d86216bf6438e92635e8.diff36
-rw-r--r--PKGBUILD9
3 files changed, 7 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54e5fdc829e9..bae91ea822ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk-gnutella
pkgdesc = A Gnutella server/client
- pkgver = 1.1.15
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = http://gtk-gnutella.sourceforge.net/
arch = i686
arch = x86_64
@@ -10,10 +10,8 @@ pkgbase = gtk-gnutella
depends = gtk2
depends = glib2
depends = desktop-file-utils
- source = http://downloads.sourceforge.net/project/gtk-gnutella/gtk-gnutella/1.1.15/gtk-gnutella-1.1.15.tar.xz
- source = 28f9cb813016803026a0d86216bf6438e92635e8.diff
- md5sums = 5d86de32939f620f31a516be6d6d6522
- md5sums = eb84ec59f24017ee3998700403186413
+ source = http://downloads.sourceforge.net/project/gtk-gnutella/gtk-gnutella/1.2.0/gtk-gnutella-1.2.0.tar.xz
+ md5sums = 01a20e2cd7ec153c9e4a5f3ef6ed5433
pkgname = gtk-gnutella
diff --git a/28f9cb813016803026a0d86216bf6438e92635e8.diff b/28f9cb813016803026a0d86216bf6438e92635e8.diff
deleted file mode 100644
index 8a64a97dbc90..000000000000
--- a/28f9cb813016803026a0d86216bf6438e92635e8.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/src/lib/xmalloc.c b/src/lib/xmalloc.c
-index 37849838e..ff55dec34 100644
---- a/src/lib/xmalloc.c
-+++ b/src/lib/xmalloc.c
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (c) 2011-2013, Raphael Manfredi
-+ * Copyright (c) 2011-2019, Raphael Manfredi
- *
- *----------------------------------------------------------------------
- * This file is part of gtk-gnutella.
-@@ -8803,6 +8803,24 @@ e_xrealloc(void *p, size_t size)
- return q;
- }
-
-+/**
-+ * This is a GNU extension.
-+ *
-+ * This function is not used by gtk-gnutella but needs to be provided when
-+ * we remap malloc() because some libc routines may rely on it. When malloc()
-+ * is redefined, it is critical that this usage be trapped here since our block
-+ * architecture is specific.
-+ * --RAM, 2019-11-10
-+ *
-+ * @return the number of usable bytes in the block of allocated memory
-+ * pointed to by `p'. If `p' is NULL, 0 is returned.
-+ */
-+size_t
-+malloc_usable_size(void *p)
-+{
-+ return xallocated(p);
-+}
-+
- /*
- * For recent MinGW startup, we need to remap strdup() as well to make sure
- * it calls our malloc(). If we let it resolve by Microsoft's C runtime, it
diff --git a/PKGBUILD b/PKGBUILD
index ee5308d02eab..756ed0fc271f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=gtk-gnutella
-pkgver=1.1.15
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="A Gnutella server/client"
arch=('i686' 'x86_64')
url="http://gtk-gnutella.sourceforge.net/"
@@ -15,16 +15,13 @@ makedepends=('pkg-config')
depends=('gtk2' 'glib2' 'desktop-file-utils')
source=(
"http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
- "28f9cb813016803026a0d86216bf6438e92635e8.diff"
)
md5sums=(
- '5d86de32939f620f31a516be6d6d6522'
- 'eb84ec59f24017ee3998700403186413'
+ '01a20e2cd7ec153c9e4a5f3ef6ed5433'
)
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < ../28f9cb813016803026a0d86216bf6438e92635e8.diff
./build.sh --prefix=/usr
}