summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--metatheme-Sonar_compatibilty-with-murrine-0.98.patch39
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f998226f9628
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gtk2-theme-sonar
+ pkgdesc = GTK2 theme from openSUSE 11.3
+ pkgver = 11.3.0_70.3
+ pkgrel = 1
+ url = http://www.opensuse.org/
+ arch = any
+ license = GPL
+ makedepends = rpmextract
+ makedepends = patch
+ depends = gtk-engine-murrine
+ source = http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/src/gtk2-metatheme-sonar-11.3.0-70.3.src.rpm
+ source = metatheme-Sonar_compatibilty-with-murrine-0.98.patch
+ md5sums = b076342ba601497a10934ede5257c2f8
+ md5sums = a47da04787410b4c62f406a1c0352c30
+
+pkgname = gtk2-theme-sonar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f30066ae09c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: John D Jones III < j n b e k join '',qw(1 9 7 2) AT gmail DOT com>
+# Contributor: Lukas Jirkovsky <l DOT jirkovsky AT gmail DOT com>
+
+pkgname=gtk2-theme-sonar
+pkgver=11.3.0_70.3
+pkgrel=1
+pkgdesc="GTK2 theme from openSUSE 11.3"
+arch=('any')
+url="http://www.opensuse.org/"
+license=('GPL')
+depends=('gtk-engine-murrine')
+makedepends=('rpmextract' 'patch')
+source=('http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/src/gtk2-metatheme-sonar-11.3.0-70.3.src.rpm' 'metatheme-Sonar_compatibilty-with-murrine-0.98.patch')
+md5sums=('b076342ba601497a10934ede5257c2f8'
+ 'a47da04787410b4c62f406a1c0352c30')
+
+package() {
+ cd "$srcdir"
+
+ rpmextract.sh gtk2-metatheme-sonar-${pkgver//_/-}.src.rpm
+ tar -xf metatheme-Sonar-${pkgver%_*}.tar.bz2
+
+ patch -p0 -b < "$srcdir"/metatheme-Sonar_compatibilty-with-murrine-0.98.patch
+ install -m 755 -d "$pkgdir"/usr/share/themes/Sonar
+ cp -a Sonar/gtk-2.0/ "$pkgdir"/usr/share/themes/Sonar
+ cp -a Sonar/metacity-1/ "$pkgdir"/usr/share/themes/Sonar
+ chmod a-w "$pkgdir"/usr/share/themes/Sonar/metacity-1
+ cp -a Sonar/index.theme "$pkgdir"/usr/share/themes/Sonar
+ chown -R root:root "$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/metatheme-Sonar_compatibilty-with-murrine-0.98.patch b/metatheme-Sonar_compatibilty-with-murrine-0.98.patch
new file mode 100644
index 000000000000..2e9151f1b4ff
--- /dev/null
+++ b/metatheme-Sonar_compatibilty-with-murrine-0.98.patch
@@ -0,0 +1,39 @@
+diff -ur Sonar.orig//gtk-2.0/gtkrc Sonar//gtk-2.0/gtkrc
+--- Sonar.orig//gtk-2.0/gtkrc 2009-10-21 00:20:34.000000000 +0530
++++ Sonar//gtk-2.0/gtkrc 2010-09-24 04:51:24.429407368 +0530
+@@ -87,7 +87,6 @@
+ roundness = 2
+ progressbarstyle = 1
+ animation = TRUE
+- gradients = TRUE
+ reliefstyle = 2
+ sliderstyle = 1
+ menustyle = 0
+@@ -142,7 +141,6 @@
+ contrast = 0.9
+ glazestyle = 0
+ gradient_shades = { 1.05, 1.0, 1.0, 0.9 }
+- gradients = TRUE
+ highlight_shade = 1.0
+ lightborder_shade = 1.4
+ lightborderstyle = 1
+@@ -158,11 +156,9 @@
+
+ engine "murrine" {
+ colorize_scrollbar = TRUE
+- gradients = TRUE
+ contrast = 0.3
+ glazestyle = 0
+ gradient_shades = { 1.1, 1.0, 1.0, 0.9 }
+- gradients = TRUE
+ highlight_shade = 1.0
+ lightborder_shade = 1.2
+ lightborderstyle = 1
+@@ -554,7 +550,6 @@
+ style "inkscape-toolbar-fix" {
+ engine "murrine"
+ {
+- gradients = TRUE
+ gradient_shades = {1.00,1.00,1.00,1.00}
+ highlight_shade = 1.00
+ }