summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--1638.patch34
-rw-r--r--PKGBUILD10
3 files changed, 5 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fb9529543a9..696b4f894457 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-patched-filechooser-icon-view
pkgdesc = GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch.
- pkgver = 3.24.17+15+gdc79e07228
+ pkgver = 3.24.17+22+g99bae0fb5f
pkgrel = 1
epoch = 1
url = https://github.com/Dudemanguy911/gtk
@@ -44,7 +44,7 @@ pkgbase = gtk3-patched-filechooser-icon-view
depends = iso-codes
depends = gtk-update-icon-cache
optdepends = glib2-patched-thumbnailer: Thumbnail generation in upload dialog
- provides = gtk3=3.24.17+15+gdc79e07228
+ provides = gtk3=3.24.17+22+g99bae0fb5f
provides = gtk3-print-backends
provides = libgtk-3.so
provides = libgdk-3.so
@@ -52,13 +52,11 @@ pkgbase = gtk3-patched-filechooser-icon-view
conflicts = gtk3
conflicts = gtk3-print-backends
replaces = gtk3-print-backends<=3.22.26-1
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=dc79e07228800dafa1062c959c68afcc7b4a1bef
- source = 1638.patch
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=99bae0fb5f714cc53b71ce93044243fb13d151ce
source = settings.ini
source = gtk-query-immodules-3.0.hook
source = gtk3-filechooser-icon-view.patch
sha256sums = SKIP
- sha256sums = 10ebcb8ec56c12e8f413c6af0c585877bca6b6530791c0c23698967a932c8e58
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
sha256sums = a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229
sha256sums = 4323c38740e2ed8f97d53538f2ba2b0ea96afae95109a69e8f165ab4d3258909
diff --git a/1638.patch b/1638.patch
deleted file mode 100644
index acdb5fe0ebbc..000000000000
--- a/1638.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c5d9c8be2bda087ce33b36f46971dfb77f976827 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
-Date: Mon, 6 Apr 2020 14:20:43 +0200
-Subject: [PATCH] wayland: Always store unconfigured size
-
-This means it'll always be as up to date GdkWindow::width/height. We
-still skip the resize for non-configured windows though, to avoid
-mapping with the wrong size.
-
-The commit f06ee688fe86ec8e1db1c515a7bf2ccc8decc310 also accidentally
-removed the unconfigured size setting completely, so this essentially
-adds it back, but always sets it.
-
-Closes: https://gitlab.gnome.org/GNOME/gtk/-/issues/2582
----
- gdk/wayland/gdkwindow-wayland.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/gdk/wayland/gdkwindow-wayland.c b/gdk/wayland/gdkwindow-wayland.c
-index f6acc74366..30d4353826 100644
---- a/gdk/wayland/gdkwindow-wayland.c
-+++ b/gdk/wayland/gdkwindow-wayland.c
-@@ -1156,6 +1156,8 @@ gdk_wayland_window_maybe_configure (GdkWindow *window,
- gboolean is_xdg_popup;
- gboolean is_visible;
-
-+ impl->unconfigured_width = calculate_width_without_margin (window, width);
-+ impl->unconfigured_height = calculate_height_without_margin (window, height);
-
- if (should_inhibit_resize (window))
- return;
---
-2.24.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 5c13100bdfd7..404443a52b9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=gtk3-patched-filechooser-icon-view
-pkgver=3.24.17+15+gdc79e07228
+pkgver=3.24.17+22+g99bae0fb5f
pkgrel=1
epoch=1
pkgdesc="GTK3 patched with dudemanguy's fork of wfr's filechooser-icon-view patch."
@@ -22,15 +22,13 @@ makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson)
license=(LGPL)
install=gtk3.install
-_commit=dc79e07228800dafa1062c959c68afcc7b4a1bef # gtk-3-24
+_commit=99bae0fb5f714cc53b71ce93044243fb13d151ce # gtk-3-24
source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
- 1638.patch
settings.ini
gtk-query-immodules-3.0.hook
gtk3-filechooser-icon-view.patch)
sha256sums=('SKIP'
- '10ebcb8ec56c12e8f413c6af0c585877bca6b6530791c0c23698967a932c8e58'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229'
'4323c38740e2ed8f97d53538f2ba2b0ea96afae95109a69e8f165ab4d3258909')
@@ -44,10 +42,6 @@ prepare() {
# apply icon-view patch
git apply -3 ../gtk3-filechooser-icon-view.patch
-
- # https://bugs.archlinux.org/task/66106
- # https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/1638
- git apply -3 ../1638.patch
}
build() {