summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--typeahead.patch12
3 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf0056aafda..7081ef0db5f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.18.2
+ pkgver = 3.18.3
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -29,16 +29,17 @@ pkgbase = gtk3-typeahead
depends = adwaita-icon-theme
depends = json-glib
depends = rest
+ depends = librsvg
depends = gtk-update-icon-cache
optdepends = libcanberra: gtk3-widget-factory demo
- provides = gtk3=3.18.2
+ provides = gtk3=3.18.3
conflicts = gtk3
- source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.2.tar.xz
+ source = https://download.gnome.org/sources/gtk+/3.18/gtk+-3.18.3.tar.xz
source = settings.ini
source = typeahead.patch
- sha256sums = 5dbec561c4a00070073bf9cf4cfdd61fab4a14c8ff5b15d700bd378f8185e152
+ sha256sums = f3c76791f93f51e260b03676f83007730b9875a0a9bf5cd42442e2f14e593546
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
- sha256sums = aafa56d981ef408f85b103ded3e15920ab96cda74e7501f970184dae38f8f791
+ sha256sums = b915590f309e27a5c430ee692edaff23e51064fc86ff8e159629ef13e4d86646
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index ce6b1f6201c0..681abebc7f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.18.2
+pkgver=3.18.3
pkgrel=1
conflicts=(gtk3)
-provides=('gtk3=3.18.2')
+provides=('gtk3=3.18.3')
pkgdesc="GTK+ 3 with typeahead feature enabled for the file chooser widget"
arch=(i686 x86_64)
url="http://www.gtk.org/"
install=gtk3.install
depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
- adwaita-icon-theme json-glib rest gtk-update-icon-cache)
+ adwaita-icon-theme json-glib rest librsvg gtk-update-icon-cache)
optdepends=('libcanberra: gtk3-widget-factory demo')
makedepends=(gobject-introspection libcanberra)
license=(LGPL)
source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
settings.ini typeahead.patch)
-sha256sums=('5dbec561c4a00070073bf9cf4cfdd61fab4a14c8ff5b15d700bd378f8185e152'
+sha256sums=('f3c76791f93f51e260b03676f83007730b9875a0a9bf5cd42442e2f14e593546'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
- 'aafa56d981ef408f85b103ded3e15920ab96cda74e7501f970184dae38f8f791')
+ 'b915590f309e27a5c430ee692edaff23e51064fc86ff8e159629ef13e4d86646')
prepare() {
cd gtk+-$pkgver
diff --git a/typeahead.patch b/typeahead.patch
index 9ac6f1547b94..4abfab88cfb2 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -1,4 +1,4 @@
-@@ -1379,12 +1379,6 @@
+@@ -1382,12 +1382,6 @@
return TRUE;
}
}
@@ -11,7 +11,7 @@
if (GTK_WIDGET_CLASS (gtk_file_chooser_widget_parent_class)->key_press_event (widget, event))
return TRUE;
-@@ -2453,7 +2447,7 @@
+@@ -2456,7 +2450,7 @@
{
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -20,7 +20,7 @@
gtk_tree_view_column_set_sort_column_id (priv->list_name_column, MODEL_COL_NAME);
gtk_tree_view_column_set_sort_column_id (priv->list_time_column, MODEL_COL_TIME);
-@@ -4348,6 +4342,7 @@
+@@ -4351,6 +4345,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->browse_files_model));
update_columns (impl, FALSE, _("Modified"));
@@ -28,7 +28,7 @@
file_list_set_sort_column_ids (impl);
set_sort_column (impl);
profile_msg (" gtk_tree_view_set_model end", NULL);
-@@ -7084,10 +7079,6 @@
+@@ -7087,10 +7082,6 @@
{
GList *l, *files, *files_with_info, *infos;
GFile *file;
@@ -39,7 +39,7 @@
files = NULL;
files_with_info = NULL;
-@@ -7115,8 +7106,6 @@
+@@ -7118,8 +7109,6 @@
g_list_free_full (infos, g_object_unref);
gtk_stack_set_visible_child_name (GTK_STACK (impl->priv->browse_files_stack), "list");
@@ -48,7 +48,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7450,7 +7439,7 @@
+@@ -7453,7 +7442,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));