summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--typeahead.patch16
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deeb0b9d18e4..94b7d01919d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Apr 10 06:11:23 UTC 2016
+# Wed Apr 13 18:55:00 UTC 2016
pkgbase = gtk3-typeahead
pkgdesc = GTK+ 3 with typeahead feature enabled for the file chooser widget
- pkgver = 3.20.2
+ pkgver = 3.20.3
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -36,14 +36,14 @@ pkgbase = gtk3-typeahead
depends = gtk-update-icon-cache
depends = wayland-protocols
optdepends = libcanberra: gtk3-widget-factory demo
- provides = gtk3=3.20.2
+ provides = gtk3=3.20.3
conflicts = gtk3
- source = https://download.gnome.org/sources/gtk+/3.20/gtk+-3.20.2.tar.xz
+ source = https://download.gnome.org/sources/gtk+/3.20/gtk+-3.20.3.tar.xz
source = settings.ini
source = typeahead.patch
- sha256sums = 1ab1d1068ea55e0046f437d69983f164df5e68cb2e9fdfb38787b867f33f69f7
+ sha256sums = 3834f3bf23b260b3e5ebfea41102e2026a8af29e36c3620edf4a5cf05e82f694
sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
- sha256sums = 4e3f2c47eeb088de08dae332ae9aedcfd1c118bf899517233b52effd2d37020b
+ sha256sums = 5b3b9ba35378515359a25714e7c185783d15ec97c137e3564fcb1dbe658c941f
pkgname = gtk3-typeahead
install = gtk3.install
diff --git a/PKGBUILD b/PKGBUILD
index 1cebbcc9c2cc..f1363adf9e1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.20.2
+pkgver=3.20.3
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver")
@@ -17,9 +17,9 @@ makedepends=(gobject-introspection libcanberra gtk-doc)
license=(LGPL)
source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
settings.ini typeahead.patch)
-sha256sums=('1ab1d1068ea55e0046f437d69983f164df5e68cb2e9fdfb38787b867f33f69f7'
+sha256sums=('3834f3bf23b260b3e5ebfea41102e2026a8af29e36c3620edf4a5cf05e82f694'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
- '4e3f2c47eeb088de08dae332ae9aedcfd1c118bf899517233b52effd2d37020b')
+ '5b3b9ba35378515359a25714e7c185783d15ec97c137e3564fcb1dbe658c941f')
prepare() {
cd gtk+-$pkgver
diff --git a/typeahead.patch b/typeahead.patch
index 0102d98d4e44..4aa4f34d03ee 100644
--- a/typeahead.patch
+++ b/typeahead.patch
@@ -1,4 +1,4 @@
-@@ -1378,6 +1378,9 @@
+@@ -1370,6 +1370,9 @@
{
GtkFileChooserWidget *impl = (GtkFileChooserWidget *) widget;
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -8,7 +8,7 @@
if (should_trigger_location_entry (impl, event))
{
-@@ -1388,12 +1391,6 @@
+@@ -1380,12 +1383,6 @@
return TRUE;
}
}
@@ -21,7 +21,7 @@
if (GTK_WIDGET_CLASS (gtk_file_chooser_widget_parent_class)->key_press_event (widget, event))
return TRUE;
-@@ -2463,7 +2460,7 @@
+@@ -2455,7 +2452,7 @@
{
GtkFileChooserWidgetPrivate *priv = impl->priv;
@@ -30,7 +30,7 @@
gtk_tree_view_column_set_sort_column_id (priv->list_name_column, MODEL_COL_NAME);
gtk_tree_view_column_set_sort_column_id (priv->list_time_column, MODEL_COL_TIME);
-@@ -4375,6 +4372,7 @@
+@@ -4367,6 +4364,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->browse_files_model));
update_columns (impl, FALSE, _("Modified"));
@@ -38,7 +38,7 @@
file_list_set_sort_column_ids (impl);
set_sort_column (impl);
profile_msg (" gtk_tree_view_set_model end", NULL);
-@@ -7121,10 +7119,6 @@
+@@ -7113,10 +7111,6 @@
{
GList *l, *files, *files_with_info, *infos;
GFile *file;
@@ -49,7 +49,7 @@
files = NULL;
files_with_info = NULL;
-@@ -7152,8 +7146,6 @@
+@@ -7144,8 +7138,6 @@
g_list_free_full (infos, g_object_unref);
gtk_stack_set_visible_child_name (GTK_STACK (impl->priv->browse_files_stack), "list");
@@ -58,7 +58,7 @@
}
/* Callback used from GtkSearchEngine when the query is done running */
-@@ -7471,6 +7463,7 @@
+@@ -7463,6 +7455,7 @@
gtk_tree_sortable_set_sort_column_id (GTK_TREE_SORTABLE (priv->recent_model),
GTK_TREE_SORTABLE_DEFAULT_SORT_COLUMN_ID,
GTK_SORT_DESCENDING);
@@ -66,7 +66,7 @@
}
typedef struct
-@@ -7488,7 +7481,7 @@
+@@ -7480,7 +7473,7 @@
gtk_tree_view_set_model (GTK_TREE_VIEW (priv->browse_files_tree_view),
GTK_TREE_MODEL (priv->recent_model));