summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD87
-rw-r--r--gtk-query-immodules-3.0.hook11
-rw-r--r--gtk3.install12
-rw-r--r--settings.ini4
5 files changed, 83 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b224b402c913..10eead7413d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk3-ubuntu
- pkgdesc = GObject-based multi-platform toolkit (v3)
- pkgver = 3.18.6
+ pkgdesc = GObject-based multi-platform toolkit
+ pkgver = 3.20.8
pkgrel = 1
url = http://www.gtk.org/
install = gtk3.install
@@ -8,15 +8,17 @@ pkgbase = gtk3-ubuntu
arch = x86_64
license = LGPL
makedepends = gobject-introspection
+ makedepends = libcanberra
+ makedepends = gtk-doc
depends = atk
depends = cairo
- depends = gtk-update-icon-cache
depends = libcups
- depends = libepoxy
depends = libxcursor
depends = libxinerama
depends = libxrandr
depends = libxi
+ depends = libepoxy
+ depends = gdk-pixbuf2
depends = libxcomposite
depends = libxdamage
depends = pango
@@ -28,13 +30,21 @@ pkgbase = gtk3-ubuntu
depends = adwaita-icon-theme
depends = json-glib
depends = rest
+ depends = librsvg
depends = wayland-protocols
- provides = gtk3=3.18.6
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ optdepends = libcanberra: gtk3-widget-factory demo
+ provides = gtk3=3.20.8
conflicts = gtk3
- source = http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.18/gtk+-3.18.6.tar.xz
- source = http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_3.18.6-1ubuntu1~wily1.debian.tar.xz
- sha512sums = a606bfeb7e6991c9c367d6c93d04d70daed6c59b95d1ef14b971acb32b23e71894b0aef16b4c673e1cb2ae0fd08de3f65b7aa5512fd74253efe30f16b0dbac11
- sha512sums = 03296946286788d96572b7a17381191ee86d30736f652f678190b0c305ab70b10c65b0d732e213745bb24e44c3981c7dcafb1e83d0c519deef440fa25a36e00f
+ source = https://download.gnome.org/sources/gtk+/3.20/gtk+-3.20.8.tar.xz
+ source = settings.ini
+ source = gtk-query-immodules-3.0.hook
+ source = http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_3.20.8-1ubuntu0~ppa1.debian.tar.xz
+ sha512sums = 9f5d29dc0ec06ce28f8b45da2e39e1d4e50cdd6b98bd0355b62c62a76aa868b596e113d68d99875b3ac18dc07d08d3fa4d6f8d3b69b61fdb3de0b244f5bb0cb5
+ sha512sums = ad2c0b0388f4169592b9574f0b3db673a969b7c4721548c4ac7c438eddbcdc378fcaac04e2b6c858a1562cc23ddf4804e5f7be08068340b7c9365e2b11ddcfb8
+ sha512sums = f0ffd95544863f2e10fda81488b4727aa9a8a35a7d39fb96872db6664d03442db2b58af788b5990825c7b3a83681f7220ca481409cca5421dfb39b9a3bbac9ac
+ sha512sums = 4034bce60e78a59d9982e315b4ec89b3c703f792d38c7c2020ae5096b60156798d872ad2db80f0c5055648e4ed600a85bd9bc1b6f7bec757635e61d991b608d4
pkgname = gtk3-ubuntu
diff --git a/PKGBUILD b/PKGBUILD
index ac277939b28c..a37fdc762306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,74 +1,79 @@
-# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Contributor: Christopher Reimer <github@creimer.net>
# vercheck-pkgbuild: auto
# vercheck-ubuntu: name=gtk+3.0, repo=xenial
# vercheck-archlinux: name=gtk3, repo=extra, arch=x86_64
-# vercheck-gnome: name=gtk+, majorver=3.18
+# vercheck-gnome: name=gtk+, majorver=3.20
# vercheck-ppa: name=gtk+3.0, url=ppa:gnome3-team/gnome3-staging
_use_ppa=true
pkgname=gtk3-ubuntu
-_ppa_rel=1ubuntu1~wily1
-#_ubuntu_rel=1ubuntu2
-#_ubuntu_ver=3.18.9
-pkgver=3.18.6
+_ubuntu_rel=1ubuntu0~ppa1
+pkgver=3.20.8
pkgrel=1
-pkgdesc="GObject-based multi-platform toolkit (v3)"
+pkgdesc="GObject-based multi-platform toolkit"
arch=(i686 x86_64)
url="http://www.gtk.org/"
install=gtk3.install
-depends=(atk cairo gtk-update-icon-cache libcups libepoxy libxcursor libxinerama
- libxrandr libxi libxcomposite libxdamage pango shared-mime-info
- colord at-spi2-atk wayland libxkbcommon adwaita-icon-theme
- json-glib rest wayland-protocols)
-makedepends=(gobject-introspection)
+depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy
+ gdk-pixbuf2 libxcomposite libxdamage pango shared-mime-info colord
+ at-spi2-atk wayland libxkbcommon adwaita-icon-theme json-glib rest
+ librsvg wayland-protocols desktop-file-utils gtk-update-icon-cache)
+makedepends=(gobject-introspection libcanberra gtk-doc)
+optdepends=('libcanberra: gtk3-widget-factory demo')
provides=("gtk3=${pkgver}")
conflicts=(gtk3)
license=(LGPL)
-source=("http://ftp.gnome.org/pub/GNOME/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz")
+source=("https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
+ settings.ini
+ gtk-query-immodules-3.0.hook)
if [[ "${_use_ppa}" != "true" ]]; then
source+=("https://launchpad.net/ubuntu/+archive/primary/+files/gtk+3.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz")
else
- source+=("http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_${_ppa_ver:-${pkgver}}-${_ppa_rel}.debian.tar.xz")
+ source+=("http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz")
fi
-sha512sums=('a606bfeb7e6991c9c367d6c93d04d70daed6c59b95d1ef14b971acb32b23e71894b0aef16b4c673e1cb2ae0fd08de3f65b7aa5512fd74253efe30f16b0dbac11'
- '03296946286788d96572b7a17381191ee86d30736f652f678190b0c305ab70b10c65b0d732e213745bb24e44c3981c7dcafb1e83d0c519deef440fa25a36e00f')
+sha512sums=('9f5d29dc0ec06ce28f8b45da2e39e1d4e50cdd6b98bd0355b62c62a76aa868b596e113d68d99875b3ac18dc07d08d3fa4d6f8d3b69b61fdb3de0b244f5bb0cb5'
+ 'ad2c0b0388f4169592b9574f0b3db673a969b7c4721548c4ac7c438eddbcdc378fcaac04e2b6c858a1562cc23ddf4804e5f7be08068340b7c9365e2b11ddcfb8'
+ 'f0ffd95544863f2e10fda81488b4727aa9a8a35a7d39fb96872db6664d03442db2b58af788b5990825c7b3a83681f7220ca481409cca5421dfb39b9a3bbac9ac'
+ '4034bce60e78a59d9982e315b4ec89b3c703f792d38c7c2020ae5096b60156798d872ad2db80f0c5055648e4ed600a85bd9bc1b6f7bec757635e61d991b608d4')
prepare() {
cd "gtk+-${pkgver}"
- # Apply Ubuntu Patches
- echo > ../debian/patches/series
-
- # https://bugs.launchpad.net/indicator-messages/+bug/1088162
- # Dependency check: grep -R ubuntu-private.h * | cut -d/ -f1
- echo 'ubuntu_gtk_custom_menu_items.patch' >> ../debian/patches/series
- # Do not allow offscreen widgets to grab the cursor
- echo '016_no_offscreen_widgets_grabbing.patch' >> ../debian/patches/series
- echo '017_no_offscreen_device_grabbing.patch' >> ../debian/patches/series
- # Allow printing to printers advertised using Avahi/Bonjour when CUPS 1.6
- echo 'print-dialog-show-options-of-remote-dnssd-printers.patch' >> ../debian/patches/series
- # Unity-specific
- #echo '0001-Add-style-classes-to-the-title-buttons.patch' >> ../debian/patches/series
- echo 'message-dialog-restore-traditional-look-on-unity.patch' >> ../debian/patches/series
- # Other
- echo 'bzg_gtkcellrenderer_grabbing_modifier.patch' >> ../debian/patches/series
- for i in $(grep -v '#' ../debian/patches/series); do
+ local patches=(
+ 016_no_offscreen_widgets_grabbing.patch
+ 017_no_offscreen_device_grabbing.patch
+ 060_ignore-random-icons.patch
+ 073_treeview_almost_fixed.patch
+ 074_eventbox_scroll_mask.patch
+ bzg_gtkcellrenderer_grabbing_modifier.patch
+ ubuntu_gtk_custom_menu_items.patch
+ print-dialog-show-options-of-remote-dnssd-printers.patch
+ uimanager-guard-against-nested-node-updates.patch
+ x-canonical-accel.patch
+ message-dialog-restore-traditional-look-on-unity.patch
+ restore_filechooser_typeaheadfind
+ 0001-calendar-always-emit-day-selected-once.patch
+ 0001-gtkwindow-set-transparent-background-color.patch
+ ubuntu_fileselector_behaviour.patch
+ )
+
+ for i in "${patches[@]}"; do
msg "Applying ${i} ..."
patch -p1 -i "../debian/patches/${i}"
done
+
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "gtk+-${pkgver}"
- autoreconf -vfi
-
- #CXX=/bin/false ./configure \
- ./configure \
+ CXX=/bin/false ./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -86,5 +91,11 @@ build() {
package() {
cd "gtk+-${pkgver}"
make DESTDIR="${pkgdir}" install
- rm -f "$pkgdir/usr/bin/gtk-update-icon-cache"
+
+ install -Dm644 ../settings.ini \
+ "${pkgdir}"/usr/share/gtk-3.0/settings.ini
+ install -Dm644 ../gtk-query-immodules-3.0.hook \
+ "${pkgdir}"/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook
+
+ rm "${pkgdir}"/usr/bin/gtk-update-icon-cache
}
diff --git a/gtk-query-immodules-3.0.hook b/gtk-query-immodules-3.0.hook
new file mode 100644
index 000000000000..c7703cf432c1
--- /dev/null
+++ b/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/gtk3.install b/gtk3.install
index 92341331ab9d..a0e620af1759 100644
--- a/gtk3.install
+++ b/gtk3.install
@@ -1,7 +1,4 @@
post_install() {
- /usr/bin/gtk-query-immodules-3.0 --update-cache
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
- /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
echo "If you want to use the global menus and you are not using Unity, you will need"
echo "to add the following to ~/.config/gtk-3.0/settings.ini"
echo
@@ -11,15 +8,6 @@ post_install() {
echo "********************************"
}
-post_upgrade() {
- post_install
-}
-
pre_remove() {
rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
- /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
diff --git a/settings.ini b/settings.ini
new file mode 100644
index 000000000000..921d1ddeec01
--- /dev/null
+++ b/settings.ini
@@ -0,0 +1,4 @@
+[Settings]
+gtk-icon-theme-name = Adwaita
+gtk-theme-name = Adwaita
+gtk-font-name = Cantarell 11