summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD33
-rw-r--r--gtkcord3.desktop9
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42a21818df25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gtkcord3
+ pkgdesc = Discord client written in go and gtk3
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/diamondburned/gtkcord3
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ depends = gtk3
+ depends = discordlogin-git
+ provides = gtkcord3
+ conflicts = gtkcord3-git
+ source = https://github.com/diamondburned/gtkcord3/archive/v0.0.1.tar.gz
+ source = gtkcord3.desktop
+ sha256sums = 371a4c34528a1be8e00ad706724a31e1a0e2f08d1a5580dabbbc384f77697c9b
+ sha256sums = 8839b86e0a4174d5b5f3f7aa1248ee6af26901e4b5d4e749088444e1861982a4
+
+pkgname = gtkcord3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0799db0bcba1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=gtkcord3
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Discord client written in go and gtk3'
+arch=('any')
+url='https://github.com/diamondburned/gtkcord3'
+license=('GPL3')
+depends=('gtk3' 'discordlogin-git')
+conflicts=('gtkcord3-git')
+provides=('gtkcord3')
+makedepends=('git' 'go')
+source=('https://github.com/diamondburned/gtkcord3/archive/v0.0.1.tar.gz'
+ 'gtkcord3.desktop')
+sha256sums=('371a4c34528a1be8e00ad706724a31e1a0e2f08d1a5580dabbbc384f77697c9b'
+ '8839b86e0a4174d5b5f3f7aa1248ee6af26901e4b5d4e749088444e1861982a4')
+
+build() {
+ # check if user has already set their GoLang path
+ if [[ -z "${GOPATH}" ]]; then
+ GOPATH="${srcdir}/go"
+ fi
+ cd $pkgname-$pkgver
+ go build -trimpath
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 gtkcord/components/logo/logo.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/gtkcord.png"
+}
+
diff --git a/gtkcord3.desktop b/gtkcord3.desktop
new file mode 100644
index 000000000000..e225e78c949e
--- /dev/null
+++ b/gtkcord3.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=gtkcord
+Comment=A lightweight Discord client which uses GTK3 for the user interface.
+Exec=gtkcord3
+Icon=gtkcord
+Terminal=false
+Type=Application
+Categories=Network;InstantMessaging;P2P;
+