summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1deab4086243..e6a5c77a6387 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = gtkhtml4-git
pkgdesc = A lightweight HTML renderer/editor widget for GTK3
pkgver = latest
- pkgrel = 2
- url = https://github.com/GNOME/gtkhtml
+ pkgrel = 3
+ url = https://gitlab.gnome.org/Archive/gtkhtml
arch = i686
arch = x86_64
license = GPL
@@ -15,10 +15,9 @@ pkgbase = gtkhtml4-git
depends = iso-codes>=0.49
provides = gtkhtml4
conflicts = gtkhtml4
- source = gtkhtml4::git+https://github.com/GNOME/gtkhtml.git
+ source = gtkhtml4::git+https://gitlab.gnome.org/Archive/gtkhtml.git
source = enchant-2.patch
sha256sums = SKIP
sha256sums = 2b78f071f7893e19618959443f3775bd435941a37ea9198b2fe72b596c205891
pkgname = gtkhtml4-git
-
diff --git a/PKGBUILD b/PKGBUILD
index fe3e83caa3c5..b5d62ddb419a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Maintainer: Jonathon Fernyhough <jonathon at_manjaro dot_org>
+# Maintainer: Jonathon Fernyhough <jonathon at_m2x+dev>
# Contributor: Gaming4JC
# Previous Maintainer: Ionut Biru <ibiru@archlinux.org>
pkgname=gtkhtml4-git
-_pkgbasename=gtkhtml
-pkgver=latest
-pkgrel=2
+pkgver=4.10.0.r10.g4b6f74dc
+pkgrel=1
pkgdesc="A lightweight HTML renderer/editor widget for GTK3"
arch=(i686 x86_64)
license=('GPL')
@@ -18,12 +17,18 @@ depends=('cairo>=1.10.0'
'gtk3>=3.2.0'
'iso-codes>=0.49')
makedepends=('intltool')
-url='https://github.com/GNOME/gtkhtml'
-source=("${pkgname/-git/}::git+https://github.com/GNOME/${_pkgbasename}.git"
+url='https://gitlab.gnome.org/Archive/gtkhtml'
+source=("${pkgname/-git/}::git+${url}.git"
'enchant-2.patch')
sha256sums=('SKIP'
'2b78f071f7893e19618959443f3775bd435941a37ea9198b2fe72b596c205891')
+pkgver() {
+ cd "${pkgname/-git/}"
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ git describe --long 2>/dev/null | sed 's/GTKHTML_//; s/\([^-]*-g\)/r\1/; s/[-_]/./g'
+}
+
prepare() {
cd "${pkgname/-git/}"
patch -Np0 < ../enchant-2.patch