summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--gtkparasite-git.install16
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85b183681676
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gtkparasite-git
+ pkgdesc = GTK+ debugging and development tool for GTK+3 applications
+ pkgver = 0.3.0.r95.445cd7a
+ pkgrel = 2
+ url = http://chipx86.github.io/gtkparasite/
+ install = gtkparasite-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gnome-common
+ depends = python2
+ depends = gtksourceview3
+ depends = gsettings-desktop-schemas
+ options = !libtool
+ source = gtkparasite-git::git://github.com/chipx86/gtkparasite.git
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = gtkparasite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b491f5b1e12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: Hagen Schink <troja84@googlemail.com>
+
+pkgname=gtkparasite-git
+pkgver=0.3.0.r95.445cd7a
+pkgrel=2
+pkgdesc="GTK+ debugging and development tool for GTK+3 applications"
+url=http://chipx86.github.io/gtkparasite/
+arch=(i686 x86_64)
+license=(MIT)
+depends=('python2' 'gtksourceview3' 'gsettings-desktop-schemas')
+makedepends=('git' 'gnome-common')
+options=(!libtool)
+source=("${pkgname}"::"git://github.com/chipx86/${pkgname%%-*}.git")
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${pkgname}"
+ echo $(awk -F , '/^AC_INIT/ {print $2}' configure.ac | tr -d '[ ]').r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ # Replace old AutoMake macro with new one
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' "${pkgname}/configure.ac"
+}
+
+build() {
+ cd "${pkgname}"
+ PYTHON=python2 ./autogen.sh --prefix=/usr --with-gtk=3.0
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
diff --git a/gtkparasite-git.install b/gtkparasite-git.install
new file mode 100644
index 000000000000..562da908b2a6
--- /dev/null
+++ b/gtkparasite-git.install
@@ -0,0 +1,16 @@
+post_install()
+{
+ cat << EOF
+
+To use gtkparasite for a GTK+ 3.0 application execute:
+GTK_MODULES=gtkparasite gtk3-application
+like:
+GTK_MODULES=gtkparasite gedit
+
+EOF
+}
+
+post_upgrade()
+{
+ post_install
+}